All audio interface input channels have disappeared

Windows 10, Ardour 5. Focusrite Clarett 4 Pre. Thunderbolt connection. Installed 6.2 this afternoon and all audio input channels from the interface were no longer present in the audio connections window, only System Input 1 and System Input 2. Testing mic on the Clarett showed signal reaching proper channels, but no signal through to Ardour tracks. Opened sessions from entire album recorded earlier this year - same result: no input channels present.

Uninstalled Ardour 6.2 and reverted to earlier version of 5. Same issue.

Any insight into this from anyone?

Thanks!

Did you confirm the Focusrite is still the device being used by Ardour in the Audio/Midi Setup Dialog? It sounds like it switched to your built in input and output.

   Seablade

It’s still confirmed as the input/output in the intial Setup Dialog. It’s weird!

Out of curiosity, I haven’t used the Clarrett series but my experience with the Scarlett and Saffire series is that you set the sample rate through their control panel, is there a chance that sample rate does not match what is set in Audio/MIDI in Ardour? I remember that causing some issues and oddities in my experience.

    Seablade

Yah - I checked that one too, as I had a few at 48 and a few at 44.1. Those match as well. I am totally verklempft! I spent months with this interface and Ardour and never had a single glitch and now this has come along.

Just an update - I took off and nuked my OS from orbit to make sure, reinstalled OS, Ardour and the Focusrite Clarett 4 Pre drivers, and still the same result. Without many other programs installed, I can’t think of anything that might be competing for the same processes, although I thought maybe some nVidia driver might be mucking things up, as nVidia has audio drivers and I did install a new graphics card since I finished the CD and was regularly using the Clarett and Ardour. So I am completely mystified and not sure what other diagnostics to check.

You could install Reaper and see if it has the same problem. You might even prefer it to Ardour!

Yah - I had thought of that. I have a REAPER executable in my exe folder stash. I should do it as an equipment test, but the idea of using anything but Ardour is… um… a big step. :-p

Well, the Clarett inputs fine in REAPER. So I am assuming I have fundamentally altered some setting somewhere in Ardour, but I’ll be damned if I can find it (or when I would have changed anything - opening up files from earlier this year has the same issue). As Seablade mentioned, it is correctly selected in the initial start-up dialog, the hardware and software sample rates match, and the hardware itself is working properly… but if anyone has a suggestion as to where I might begin hacking about, that would be most excellent!!

And you remembered to check that Audio / Midi Setup window defines that all input channels are available to Ardour ?

Ardour_Input_Channels

Yes indeed! And in the Preferences. it’s also set to “Automatically connect tracks to hardware inputs”.

Maybe post a screenshot of your Audio/MIDI Setup window (like Mikael did). It might give someone a clue as to what’s wrong.

Does defining the number of input channels (8 or 4 or 2) manually in the Audio / Midi setup window help ?

Defining the specific number of inputs didn’t make a difference either.

Screenshot of the Audio/MIDI setup - initial_dialog

You should change “driver” from MME to ASIO and then check your input channels again!

1 Like

Seconded, use ASIO on Windows for professional interfaces in general.

Copy that!! It did indeed work! Thank you! Now - the question is whether I am becoming sufficiently decrepit that I forgot that I used ASIO instead of MME all along… or whether something changed…

Regardless- much appreciated and much kudos for the assistance!