Alesis io4 - mic volume

(Jonathan270571) #1

Hi, I’ve searched for Alesis io4 and can’t see anything that relates to my problem.

Equipment used…
DELL Inspiron with Ubuntu studio installed to HDD.
Alesis io4 USB audio interface
1x Samson Q-kick chann1 (no phantom)
1x Samson Q-snare chann2 (no phantom)
1x DM800 condenser chann3 (phantom)
1x NW800 condenser chann4 (phantom)

I’ve set mics as per Glynn John’s method and created a session with 4 channels in Ardour

The kick and snare dynamic mics seem to work as expected, as I increase gain on each channel the VU meters on the io4 increase as expected and the VU meters on Ardour channels show the increased gain as they should. However, even with no gain increase on channels 3&4 (condenser mics using phantom power), so gain as low as possible, the channels on Ardour are peaking. The VU meters on the io4 channels 3&4 show nothing with gain down and as I increase gain, the VU meters display correctly and indicate the increase. I KNOW that the io4 is working correctly as when it’s connected to an amp and speakers the gain can be increased and decreased, which in turn affects the volume to the speakers.

Has anyone else encountered this with the io4 or indeed another USB interface and condenser mics. I suspect I may not have Ardour input configured correctly; I start Ardour create new session, select io4 as input & output. The session opens, I create 4 tracks (1 at a time so I can name them respectively), click ‘RECORD’ on each track, press the record enable, click the ‘PLAY’ button and then play drums.

It does record each mic as a separate entity so it does work it’s just the gain is way too high.

Any ideas and help would be greatly appreciated.

Thanks for listening

Jonny

(Seablade) #2

Well Ardour will record exactly what it is given by the audio backend, so it sounds like something wrong with the setup of the io4, note that this could be something in the driver is wrong or something in the configuration is wrong. This section in the description of it makes me wonder about it:

This four-channel USB device for Mac and PC-based systems enables users to record and monitor four channels in 16-bit mode or two channels in 24-bit mode

So it sounds like there is some configuration on the audio interface itself. I suspect this might be controlled by alsamixer on Linux but am not sure. I guess one way to find out what you are doing would be to see what bit depth the interface is set to, in Jack this should be in the text as the server starts up (Visible in QJackCTL or by starting at a terminal, or you can check settings in QJackCTL). Can’t remember how to check this in Alsa off hand though sorry.

(Jonathan270571) #3

Hi Seablade thanks for your reply.

There’s nothing to configure really on the io4, there’s a hardware switch that allows you to select either 2 channel or 4 channel; phantom power switches, and the gain knobs.
Oh and a weird switch I haven’t quite worked out, something to do with channels, USB, and MAIN.
Plus the volume to MAIN and HEADPHONES.

Yes I have only tried with ALSA not JACK if this makes a difference?

I wasn’t sure whether there is input selection per track and whether it was doubling up on the input or something (to be honest I’m still learning the insurance and outs), it seemed to work okay with cubase last time I tried it but I only had 1 condenser mic at that time.

I’ll have another go, the weird thing is…last week when I tried it, channel 4 would work then suddenly go off, then come back, also seemed to be a quiet recording (think I hadn’t tweaked the gain properly and I put cutting out down to dodgy XLR cable)

I’ll start Ardour today and look again at the session/config settings. I’m not very experienced with Linux, just thought it may be more cost effective than a Windows machine (and maybe less process intensive therefore more effective)

Thanks

Jonny

(Seablade) #4

Yes there is per track selectable inputs, see #3 at this page of the manual:
http://manual.ardour.org/ardours-interface/audio-midi-mixer-strips/

      Seablade
(Len) #5

No, jack uses ALSA as well. Once the device is plugged in the 16/24 bit switch has to stay where it is. That should be changed with the device off and not connected so that alsa knows what it is dealing with. I would guess it needs to be set to 16bit for 4 inputs.

Is there any movement in the level in Ardour at all? If you switch the mics around so that the dynamic mics are 3/4 and the condensers 1/2 does that move the problem to channels 1 and 2? It almost seems there is a dc level somewhere. like there is a cap missing (or shorted). An amp connected to it would not notice this as it likely has it’s own blocking cap on the input. But the ADC may not (or it may leak if it is older). The phantom power is a large DC signal. if the mic or cable is wired wrong that could do the same thing too. Both of these problems seem odd that they would effect both mics or both cables or even both channels.

(Jonathan270571) #6

Thanks for replies…

I’m just trying other channels now…

Well tried channels 1 and 2 instead of 3 and 4; the gain controls do give some control off input BUT if the volume of the source is VERY loud, even zero gain is too much. Possibly a cheap MIC problem.

The weird thing is the VU meters show good input response but the output via USB to laptop DAW is massive. I’m trying to do some tests on Cubase but the laptop with that on has thrown a wobbler.

I shall return, thanks again.

(Jonathan270571) #7

Hi, so sorry I never came back…

I eventually got back on a working Windows laptop. I installed Cubase 5 LE. Recording with my band went well on Cubase, there was NO peaking and I had full control of mic volumes

I guess the Alesis io4 and Ardour don’t mix well at present.

Thanks for all your inputs and help.

Have a nice day

Jonny

(Robin Gareus) #8

Did you try Ardour on Windows, too? It rather sound like the issue was with ALSA on Linux, not Ardour itself.

(Jonathan270571) #9

Ah…no. I never thought of that! Oops.

Thanks for that :hugs:

I’ll give it a try when I have a minute and return with the results.

Thank you :grin:

(Robin Gareus) #10

Well, If you’re happy with cubase, that’s perfectly fine.

It could well be that for the given soundcard, it is some Linux related issue:
There is info that it works at 44.1kHz but not at 48kHz sample-rate: https://www.alsa-project.org/wiki/Matrix:Vendor-Alesis which is a bit odd to begin with.

(Jonathan270571) #11

Hi,

Thanks for getting back to me.

Yeah the Alesis is a little limited, but the sound quality is pretty good considering, and when I bought it I couldn’t get any other 4 track USB interfaces for anywhere near the money I had available at the time. I guess the problem is that it’s not one of the mainstream goto devices like the Presonus or Focusrite stuff, so has little support. It works okay with Windows but you MUST use ASIO driver for 4 track usage.

I do quite like Cubase, but I was enjoying Ardour too.

My main reason for using Ardour was… well, basically I thought using Ubuntu Studio and Ardour would lessen the Operating System overheads of Microsoft Windows…well that and Linux is free.

I’ll definitely try Ardour for Windows though, I did like it, from what usage I got of it.

Thanks again

Jonny

(Mikael Hartzell) #12

I have been using Alesis IO4 with Ardour + Linux for 4 - 5 years with no problems. The volume indication on IO4 led meters matches level shown on Ardour tracks. I have two IO4 units and both work flawlessly with Ardour on Linux. I’v been using Ardour 5.12 with IO4 from the moment 5.12 was released.

(Jonathan270571) #13

Hi,

That’s cool. I don’t know why my setup had the problems it did, maybe it was a 1 time glitch, I’ve never tried it again. The first time I tried it seemed okay, then the week after it wasn’t…!?
I may give it another try, although I’ve now got it installed on a Windows machine along with Cubase 5 LE, and Pro Tools First.

I guess I need to make up my mind which I want to continue using.

Thanks for reply

Jonny