Alesis Firewire conflict problem?

Hi, I have been using my Alesis multimix 8 firewire with Ardour for some time–like ten years. I first used it with ubuntu 10 something, I think, and then with Ubuntu 14.04, And then, I upgraded to 16.04 and made a boo, boo, As I was loading 16.04, something went weird and wrong: I ended up with a partition after my computer hung. A new 16.04 version and a 16.04 version with the 14.04 kernals. I could never get my Alesis firewire to work with the new version 16.04, but if I selected the other weird version of 16.04/partition at start up the Alesis firewire worked fine. I Used Ardour like that for years–recorded my band and others using multitracks and the mixes turned out great.

Anyway, I decided to upgrade to 19.10 and leave the old weird working partition of 16.04, and the 16.04 still works, but I am trying to get the Alesis firewire to work with 19.10 and move from Ardour 4 to Ardour 5. But I am having trouble. In 19.10, FFADO recognizes the Alesis multimix, and I went into “alsamixer” via terminal and chose the multimix from the drop down menu with the F6 command, and I then, went into Ubuntu control and chose the Alesis multimix and I got it to work sort of: I recorded with the Alesis interface in Ardour but it didn’t sound right and the computer keeps locking up.

Anyway, I think there is a conflict between my video driver and the audio driver from what I have read, but I don’t know how to fix it. I still use the Alesis multimix firewire with the old partitioned weird version of 16.04, so no rush (LOL!), but I would like to move onto Ardour 5 someday with 19.10.

Thank you so much, gordsd.

Hmm? Well, my son told me that it was probably time to update my computer with a new one and move to a new interface as well using one with the new USB -C port–which is much faster. Does anyone have any recommendations? I want to stay with Ubuntu and Ardour; are there any multi track recording interfaces which work really well with Ubuntu and Ardour? It will be on a new computer as well. Thank you in advance!

I don’t have time to type a full reply at this time sadly, but a word of caution in that USB3 (Often what is on USB-C) does not really make a difference for audio in terms of ‘speed’. USB2 was plenty fast enough for multiple channels (Without doing the math I am going to say minimum of 32) with a well designed interface, and Firewire was actually better than USB2 for many reasons.

Just wanted to give you a word of warning that a new computer will not fix your problems necessarily. But if you are replacing computer and audio card, etc. then that is a different story.

Seablade

Newer versions of Linux now have firewire audio support present in the kernel as part of ALSA. You have seen this via using “alsamixer” to control your Alesis multimix, something that is not possible if you are (only) using FFADO.

You need to be extremely careful not to accidentally be using both the ALSA firewire audio support and FFADO at the same time. In addition, it is unclear at this time if the ALSA firewire audio support for any given device is better, worse of the same as FFADO’s. So you may need to try both.

Thank you so much for the reply. I have been starting the FFADO every time with the Ubuntu Control. I will try without with different settings–or one or the other but not at the same time. Thanks!

Well, yes, I think you have a point. Under the old partition, the firewire works great still–I have recorded at least seven tracks at once with no problems at all–for years, and play back always sounded great. Anyway, my son who seems to no more about computers than me most of the time seemed to think it was time for me to update. Thank you!

In Ubuntu 19.10, I tried using Ubuntu Control without FFADO, and insided Ubuntu Control simply selected firewire from the drop down menu, and Ardour worked and recognized the firewire inputs and outputs, but play back is full of static for some reason. I also tried running FFADO and qJack apart from Ubuntu Control and Ardour worked a bit and froze. However, Ardour still works great with the setup under the old partition with the 14.04 kernels. I know there is something I am not doing right in 19.10, but I don’t know what. It is just strange, to me, that the setup works so well with the old version of Ubuntu and not the new.

I think the point you missed is that newer kernels have firewire include in the ALSA drivers, so you have to either blacklist the ALSA firewire drivers and only use FFADO, or not use FFADO and only use the ALSA firewire drivers. If you are not specifically blacklisting the ALSA drivers there is a possibility that they have already loaded and when you load FFADO (or use the “Firewire” backend in jackd) that you are creating a conflict. Check to see whether your Alesis device is detected if you only use the ALSA backend.

Thank you. I thought that is what I tried. I’ll make sure and try again.

Your wording was somewhat confusing if you thought you tried only ALSA, because you kept mentioning alsamixer and FFADO, or selecting FFADO in Ubuntu Control (I’m not familiar with that, does Ubuntu have something custom for their distribution, or do you mean QJackControl?). You never mentioned blacklisting the ALSA drivers that I saw, and you said in control you picked “firewire” from the drop down menu, but there are two selections (assuming you really meant QJackControl), one for backend and one for device. I could not tell if “firewire” was the device or the backend selection.

I do not use Ubuntu myself, but from talking to others it seems that Canonical manages to break things in their kernel builds quite frequently. Have you tried one of the audio specific distributions like AVLinux, or if you want to stick with Ubuntu, have you loaded the Ubuntu Studio repository? I would hope that Ubuntu Studio would get more audio specific testing.

You can tell if you have the ALSA drivers loaded by looking in the output of lsmod to see which snd modules are loaded:
lsmod | grep snd

If you see something like snd-firewire, snd-bebob, snd-dice, snd-oxfw then your kernel is loading the ALSA firewire drivers and you will either need to use those, or “blacklist” those (add them to a blacklist file and reboot so the kernel will not load those drivers) if you want to continue using FFADO.

Thank you, I will try that. I am not an expert with computers or Ubuntu, but I have used the older versions of Ubuntu just as they were and really did not have to do much but choose firewire and this and that from drop down menus within the different programs: Qjack. Hydrogen and Ardour for inputs and outputs. I’ve only used terminal commands very sparingly in the past–almost never. So, up until now, I’ve been trying to get the settings right from within Ubuntu Control–without starting FFADO or anything else. And I’ve tried FFADO with Qjack without ubuntu control. Anyway, I will try blacklisting thing from terminal. Thanks again.

That would only be a last resort if the ALSA drivers did not work. It still is not clear whether you have actually tried just using the ALSA drivers. I am not familiar with Ubuntu Control, searching for that phrase in google does not show something which looks specifically like an audio control application.
Typically you either use the built in Ardour audio backend and choose the audio device there, or you start jackd and choose the audio device there, either way it is separate from the audio device which the system uses, so I am not sure how Ubuntu Control fits in with using Ardour.
With either Ardour or jackd you would have to choose the backend and then choose the specific device. For jackd for example, the backend choices would be “alsa” or “firewire” and then you select which device to use (if you have more than one possible device to choose). You keep saying you chose “firewire” but it is not clear if you mean the firewire driver, or you chose the ALSA driver and your device happens to be named “firewire.” That seems less likely, I would expect the device name to have either Alesis or Multimix in the name.
If you are choosing the firewire driver, the recommendation would be to try using the alsa driver instead.

Thank you again for the help. I am going to try a few more things this morning. Ubuntu Control is a semi-new program in Ubuntu which helps organize audio: you can start and stop jack from within it and start a program called Carla where you can configure and connect the sound system; you can also chooses from drop down menus alsa, firewire, etc. The operator can also not use it, and use FFADO and jack apart form it. Anyway, I am still figuring it out. I was watching youtube videos this morning on how to use Carla which I think might be the key to configuring Ardour and the Multimix. The system does find the interface because “Multimix” shows up in the drop down menus in all of the programs. My problem is that I am just learning to configure because I always just let the computer kind of do it for me in the past and the programs would just work. Anyway, thanks again.

No, Carla is just a way to run plugins in a stand alone program for hosts which don’t support the plugin API of the plugin you want to use (e.g. you want to use a DSSI synthesizer plugin which Ardour does not support). Carla is completely unrelated to configuring Ardour, you need to get either Ardour or jackd working reliably with your interface first before worrying about plugins.

Hmm? OK. I worked on this thing again for hours: trying different configurations in Ubuntu Control and, also, using FFADO with Qjack without Alsa. Vice versa. I went into alsamixer via terminal and tried choosing mulitmix with F6 command. This shouldn’t be this hard. I am not sure what jackd is; I’m only familiar with qjack. I will search for a “jackd” ? Thank you again for the help!nnI will explore the jackd thing.

I think qjackctl is a gui for jack wich is normally ran by command line

How did you prevent the ALSA driver from loading? The kernel will load the ALSA drivers automatically, so unless you understand the process for preventing automatic loading of drivers, or you manually unloaded the kernel driver, you did not actually try without ALSA. That is why I have recommended multiple times that you try using just the ALSA drivers, forget about FFADO for now.
As Paul wrote above

I tried to warn you as well, but apparently you did not realize the implication I was pointing out of having firewire support in the ALSA drivers:

I think you have a learning curve ahead of you if you want to work against the automatically loaded kernel drivers, which is why the recommendation would be to use the ALSA drivers and not FFADO if the built in drivers work for you.

That allows you to make setting changes to the Multimix, but has almost nothing to do with setting up Ardour or jackd to use the device.

The jackd audio server is what provides the ability to connect Hydrogen and Ardour (and other audio apps) together. It manages access to the audio device, and allows routing audio and MIDI to and from different applications and the audio hardware. QJackControl (which I assume is what you are calling qjack) is a graphical application which allows you to select settings for jackd with pull down menus and then sends your selected settings to jackd, which is the application which actually runs to perform the audio routing.
QJackCtl web page
JACK audio server web page

I suspect that since things just worked for you in the past you never really needed to concern yourself with what was going on behind the scenes.

So this is my recommendation:
In QJackCtl in the setup page, in the “Driver:” drop down box, pick “alsa” as the driver type, then whatever device name looks like your mixer (will probably be hw:Multimix or something like that).
Set frames per period to 1024, which should have a reasonably good chance of running with no underruns (if this works you can refine that setting later). Use whatever sampling rate you usually use and start it up. If that works then you are good to go, just put “firewire” and “ffado” out of your head, that’s the old way of doing things.

If that does not work with your device, then you have to go against the flow a little bit to get the old way working again.
Open a text editor and create a file named something like no-alsa-fw.conf and put this text in the file:
blacklist snd-fireworks
blacklist snd-bebob
blacklist snd-oxfw
blacklist snd-dice
blacklist snd-firewire-digi00x
blacklist snd-firewire-tascam
blacklist snd-firewire-lib
blacklist snd-firewire-transceiver
blacklist snd-fireface
blacklist snd-firewire-motu

Save that file, then if you know how to use administrator privileges from your favorite graphical file utility you can move it to /etc/modprobe.d
If you are not sure about how to do that (I think the file utility should just ask for your password when you move it), then you can do this from the terminal shell (in the directory where you saved the file):
sudo mv no-alsa-fw.conf /etc/modprobe.d/

That will add the file you created to modprobe.d directory, which is searched for conf files at boot time to find the list of drivers which should not be loaded automatically. All those drivers which begin with “snd-” are ALSA drivers for firewire devices. If from the command prompt you type
lsmod | grep snd
you will probably see one or more of those drivers loaded.
After moving the file to the modprobe.d directory reboot your computer, and after restarting when you run that same lsmod command you should not see any of those firewire snd drivers loaded. Without the ALSA driver loaded you now use FFADO as you did in the past, by selecting “firewire” in the driver selection box in QJackCtl.

Thanks again Chris, ccaudie, I really appreciate your responses. I will take your advice and give what you write a try. I’ve been a little busy most of today replacing our dishwasher. I just need a bit of time at this point.