Akai APC mini: Remapped for maximum efficiency

Hi all,

first post of mine in this forum. The APC mini of Akai is officially made and designed to work with Ableton Live, but also it is a MIDI compliant device. Since Ardour does not have the session capabilities as in Ableton, and I never really used Session View (I’m more the normal timeline editing guy), I thought it could be fun to remap the APC mini to do something useful for, and with, Ardour.

The device avails of 64 pads, which are normally used for Ableton’s session items. I divided this area of pads into four 4x4 button areas, each of which does something different.

The mapping is what I believe to be very productive.

Top left: Generic Ardour functions
Top right: Track and region editing functions
Lower left: MIDI-assignable drum pad (or whatever you like
Lower right: Mute and Solo buttons for each track in the current bank

First seven buttons on the right, from top, are: Play, Pause, Global Record Arm, Play Loop Region, Back to Beginning of Session, Bank forward, Bank backward

The eight buttons above each fader enable recording for the respective track in the current bank.

To make it more understandable, I created this chart:

Here you can download the map file for Ardour:

In order to use this, you need to enable the Generic Control Surface in Ardour’s settings. As the layout, you choose the provided mapping, and check “Feedback enabled” if you want certain buttons to light up.

If you have any questions, please let me know. Also, feel free to modify to your needs.


1 Like

Thanks for this! This is really great. Worked right away for me. I wold suggest committing a pull request for this, so it can be added by default to Ardour

Hello, I just saw this and I want to apply it to my controller as well but I am too nooby and just started out with linux and Ardour. May someone help me out setting this up? I do not know how to edit Control Surfaces in the preferences…!

I’ve tried to put this on my mac in the midi_maps folder and ardour6 won’t recognize it at all. I can get it to read, but the profile won’t load at all. I don’t know what to do. I just want a control surface.

How did you get it to work right away? I’m using Mac OS Catalina. I tried to save the map xml. I’m not sure if I saved it right or not.