Akai APC key25 midi keyboard problem

The APC key25 has piano keys, pots and a button bank.
The pots and button bank are mapped onto midi channel 1.
The piano keyboard is mapped on to midi channel 2.
It works with other software like LMMS or ABleton live, but there is a problem using it with Ardour.

I have the keyboard connected to my PC running ubuntu 18.04 and ardour.
Ardour can see the keyboard and the control buttons and the piano keys all show up in the midi instrument as a yellow bar when pressed - good!

The buttons will play the instrument, but the piano keys do not make any sound they are ignored.

I have tried many ways to configure the system to make the piano keys work. I need to tell ardour to use midi notes from midi channel 2 instead of midi channel 1 but I cannot find a way to do it.
Can anyone help?

Ardour is bundled with some midi utility plugins, i think there must be a filter?

Other workaround : akai editors runs well under wine(i used mpd218 and midimix editors), you should change with the editor the midi channel.

Ableton 100% ignores MIDI channel information - it acts as if there is only 1 channel for incoming MIDI. Ardour does not do this.

You have not really defined what you mean by “make the piano keys work”. I can think of several different possibilities, so you’ll need to clarify that before we can help you further.

So does lmms until you specify the only midi channel you want to receive.

Thanks for your reply.
I add a midi instrument to the ardour editor… I drag down the instrument bottom side to reveal a piano keyboard. That onscreen keyboard allows me to play notes and hear them play.
I want my external keyboard to work the same as the onscreen keyboard. But ardour only passed the midi channel 1 signals to the instrument. Somehow I need to tell ardour to use midi channel 2 data to play the instrument notes instead of midi channel 1 data . I thought the midi channel number to use for notes would be configurable somewhere in the Ardour settings, but I cannot find it.


No. LMMS just works with the APC Key25 keyboard without any configuration. I didn’t have to do anything. But I think lmms ignores the midi channel data and passess any midi notes it receives to the instrument. The instruments that I have used also appear to ignore the midi channel number because they play without any cobnfiguration - (zynaddsubfx etc…)

I have solved my problem with the Akai APC key25 midi keyboard.
It was actually the synthesizer - zyn fusion (zynaddsubfx) which has midi channel number selection on the Part Settings - Instrument Settings panel.
I had not noticed this before, previously I had used the old zynaddsubfx interface with LMMS etc.
I set channel number to 2 and it now works correctly.


Thanks for your help!

That’s what I was saying, I didn’t get understood, sorry for that, maybe my bad english.

By the way glad to hear it’s working fine now.

I think I saw you on the lmms forum when you asked me about my ardour transition :wink:

How do you feel about Ardour now ?

I Love LMMS. It’s so easy to use, but that also makes it limited.
Ardour appears to offer a lot more but I find it difficult to learn because there are so many menus and options. I am getting there slowly.
I’m getting to like Ardour!
I watched some of the Unfa videos. He had the same transition and now he appears hooked on Ardour.
Unfortunately Ardour/Zynaddsubfx combo sometimes locks up and sometimes crashes for me. Probably my fault for expecting too much. I’m hoping the next version will be more stable.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.