After "midisport-firmware" package install can't find or configured device

Hi guys.
Incredible job everybody on Ardour! I really love the product and plan on supporting the further development of it. I’m planning on using Linux for my pro level audio production so thanks to everyone that contributes their time and skills to the cause.

I’m using Ardour 6.6 with the latest version of Ubuntu Studio 20.10 with KDE.
I have an M-Audio 2496 audio card with midi and a M-Audio Midiman/Midisport 8X8 rack mounted midi interface.

Although I have used all of this hardware before with a older version of Ardour and a difference version of Ubuntu Studio I can’t recall what had to be done to actually use any of it.
The audio portion of the M-audio 2496 is working great. The midi is not but I wasn’t really planning on using the midi on this card only the midi on the Midisport 8x8.

I installed the “midisport-firmware” package from the Ubuntu repositories and restarted the machine (not that this should be necessary). It also installs “fxload” package as it’s only dependencies.
I can’t for the life of me see any of these midi devices anywhere on the system. I open Ardour under the Midi setup. I don’t see the Midisport there either. I’m hoping I’ll get served a little “humble pie” thinking I missed a step but I can’t seem to even find any reference to the Midisport device never mind configure it.

Is there anyone out there that might point me in the right direction? I would truly appreciate it very much.
Thanks guys,
Soup

What does aplay -s say?
…and, I just remember that you probably need to load the firmware with fxload. Remembering vaguely from the days I used a 4x4 parallalel. You didn’t mention how yours is connected - If it’s USB the firmware loading part might be done by udev, once the firmware is in place.

Hi Tom,
Thanks for your time here.
The system is connected to the Midisport via USB and after running the command “amidi -l” to see if the Midisport is detected as well as the midi on the M-Audio 2496 card. This was the results of that command:
studio@studio-pc:~$ amidi -l
Dir Device Name
IO hw:0,0 M Audio Audiophile 24/96 MIDI
IO hw:1,0,0 MidiSport 8x8 MIDI 1
IO hw:1,0,1 MidiSport 8x8 MIDI 2
IO hw:1,0,2 MidiSport 8x8 MIDI 3
IO hw:1,0,3 MidiSport 8x8 MIDI 4
IO hw:1,0,4 MidiSport 8x8 MIDI 5
IO hw:1,0,5 MidiSport 8x8 MIDI 6
IO hw:1,0,6 MidiSport 8x8 MIDI 7
IO hw:1,0,7 MidiSport 8x8 MIDI 8
IO hw:1,0,8 MidiSport 8x8 Control

Yes fxload is a dependency for the “midisport-firmware” so they are both installed and are working. I’m just not clear how to get Ardour to “see” it and how to set things up. I’ve watched several videos but none of them so far are clear on setting up the midi hardware.
What do you think?

The “aplay -s” command is complaining that it needs an argument. I thought the “s” was the argument??

To be precise, “-s” is a flag, not an argument and it is also a typo :innocent: “aplay -l” (for “list”) is what I meant to type.
Nevertheless, all your Midisport’s MIDI ports are visible to the system so I can’t quite think of a reason why they should not be visible to Ardour. You took a look at the audio/midi matrix inside Ardour?

Ah I stand corrected.
Ok the result:
studio@studio-pc:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: M2496 [M Audio Audiophile 24/96], device 0: ICE1712 multi [ICE1712 multi]
Subdevices: 0/1
Subdevice #0: subdevice #0

I went into the “Windows” menu then MIDI CONNECTIONS"
I see the MIDI tracks in Ardour but no reference to Midiman/midisport anywhere.
I forgot what it should look like Tom.
I have some notes that was for a much older version of Audour. This particular notes was how to set up midi so the virtual keyboard plays the correct module/patch/channel. I doubt these notes mean anything now in the newer version as a lot of changes have been made.

In these notes I mention an “other” tab in the dialog under “Source” and “Destination” sections. I don’t have that in the midi setup window. I only have two options under both sections. : Ardour Tracks and Ardour Misc.

Where in the setup should I actually see the midi device Ardour “sees”?

I just learned something about my problem.
When I go into Windows/Audio/Midi Setup I set the Audio System to JACK because I thought this setup would all for more than one audio source (Ardour, web browser, other audio app. etc.) to be able to be used at the same time without closing every application except the one you are using at that very moment. Maybe I need to learn more about this.
When I changed it to ALSA the Midi Device Setup button became available and all of the hardware midi ports are not available!
So I guess forum topic is actually solved I guess but I’m getting “read only” messages when I open templates and every file for Ardour on this internal USB based hard drive that is separate from the OS drive but that’s another topic.

Thanks Tom. I have a LONG way to go because I know what I’m doing with Ardour but this is a good first step with the new system so thank you very much for your help.

Aaah, now I get it… sorry, took me a while. You might want to try starting jackd with QJackctrl and Ardour after that, then open QJackctrl’s “connection” menu and connect those MIDI-Ins and Outs on your 8x8 you want to use within Ardour with Ardour’s MIDI-Outs and Ins. Because if you’re running jackd (which I’d recommend) then jackd is “in command” of the routing. There are overrides but the failsafe option should be jacks connection manager.

If using jackd you have to load a bridge between ALSA MIDI and JACK MIDI. Most people use “a2jmidid -e” to export ALSA hardware ports as JACK MIDI ports. I usually start jackd with QJackctl and I have that set in the “run after jackd starts” script option in my qjackctl setup.

Although based on the use case described by Eportel, using other desktop applications with Ardour, jackd is probably not going to be as easy as would be desirable. Firefox doesn’t have native JACK support, so you have to load the pulseaudio sink, which doesn’t have very good performance and interferes with freewheeling. Paul’s recent suggestion to just use native ALSA backend, and stop the Ardour audio backend when you want to use other programs might be the best.

Yes. I, personally, use to fire up jackd while working wih Ardour. Since I keep my second pair of arms from fiddling around with Firefox on YouTube or playing video games while recording these problems do not quite occur to me. I also assume Exportel6607 who wanted to find out if Ardour gets to see his MIDI channels at all might be able to resist starting a host of alsa-based apps while doing so. I have, BTW, no real clue if the distro they’re using is infested with PulseAudio or if Ubuntu Studio might do something reasonable to handle audio between studio apps.

TL;DR: I’d wait for problems to actually occur before bringing up a dozen of new topics. I’ve also heard of people being struck be meteorites while using jackd but I am not going to discuss the astrophysics of the Oort cloud here, just in case of.