Administrative user necessary?

hello I am sending this from my mobile phone so excuse my grammar spelling and punctuation please. I ran into some difficulty using ardour3 on my daughters account tusing Ubuntu it had trouble creating the ardor session and I wonder if ardour has to be run as an administrative user?

where are you creating the session? are you trying to put it somewhere that the permisions dont allow writing too on

You should never run ardour as the administrative user. Ever.

You should not run Jack as an administrative user either, that will make it seem like you need to run Ardour as one, and it indicates you are running Jack wrong. You do however need to make sure your system is set up for realtime pre-emption, and that the user is set up with privileges for this. This varies depending on your distribution of Linux, but this is a good starting point to learn how to do this(Link to Wayback machine as the site is currently down)…


no dont run it as root as others have said,

make sure you are creating the session in your daughters accounts home directory, if you try and create it in another accounts directory it wont be allowed since each user account only has access to there folders, also you cant store it anywhere else on the root file system siince most of those folders permissions are different to stop the system being messed up.

Pretty much each user has write access only in there home folder,

Also as seablad mentioned check that each user that is using ardour is setup for Realtime, each user needs to be added to the audio group.

thanks. the problem is/was i was trying to set up Ardour on a laptop for daughter (Ubuntu 14.04 LTS - using Software Center or whatever its called) so she could use it with a presonus audiobox usb to do simple guitar and vocal multitracking 2 to 5 audio tracks.

I installed everything from my administrative account. Then when i login to her account (non administrative), i run jack (i have different questions about that – can jack seriously NOT use the laptop’s speakers (built in audio) for monitoring/playback, while at the same time take it’s audio INPUT from the presonus audiobox usb??), and i run ardour, and when ardour opens it asks me to either open an existing, or a new sesion. I prviously created a folder in her home folder (/home/daughter/Studio/ardour/) using her login (so it’s her owner/group. But when i try to create the new session in there, we get permission denied.

(side rant… lol… I enjoy Ubuntu – but one of the big things that can get so annoying about it is, that even though it’s so powerful ultimately, there are so many situations where “it just works” could be very much possible, but isn’t engineered in. There’s a balance between having everything with pentagon-like security, and being able to achieve efficiency and humming interoperability. Software for everyday use shouldn’t require a degree in Unix Systems Deployment and Security. I’m trying to protect her from the evils of microsofty only to be face by the daemons of linux – lol)

by the way, thank you for the responses! <3

etyrnal: one of the main reasons why linux is so much more secure than windows (not 100% secure, just much more secure than windows) is precisely because it does recognize that actually software security is a complex task and that it is very very easy to make a mistake that can allow malicious damage. Part of the linux approach to this (shared with all *nix) systems is to strongly differentiate between what different users can and cannot do, and in particular to stop one user from having free access to resources owned by another user. This is why you were required to have administrative priviledge in order to install software - ordinary users cannot be allowed to do this.

The problem with the session open issue is not caused by Ardour or root issues, but by the way Ardour has been packaged by Ubuntu. You are suffering from a bug that is actually a bug in a separate software library which affects Ardour. If you got Ardour from, this problem would not occur. I appreciate that the need/benefit of getting Ardour from is not very apparent when Ubuntu appears to have it in their software center. Over the years, various Linux distributions have made several errors packaging Ardour, which is why I offer ready-to-run bundles of the application that will run on any version of Linux (at least on Intel-compatible CPUs), at Many people manage with the distribution-packaged version.

can jack seriously NOT use the laptop's speakers (built in audio) for monitoring/playback, while at the same time take it's audio INPUT from the presonus audiobox usb??)

If two audio interfaces run on different clocks (even at nominally the same frequency), there is no way that Jack can synchronise to both of them.

That’s why (proper, expensive) professional audio interfaces have a “word clock” input/output, so your whole studio can run on one clock. But your laptop internal speaker driver won’t have that…

anahata is right, its not so simple to use one interface for input and the other for output, while there is hacks to that could make 2 seperate interfaces work together, getting them to synchronise would be a problem.

ideally you want to use the same input for output aswell.

make a one of payment to download ardour, its worth the money considering how much it protools or other similar software costs to buy that runs on windows or mac.

$5 is nothing especially since you get access to the updates aswell for free. compare that to whatever protools cost.

ardour is open source, so that is why you see it in distros because they can put the work in and compile it and provide prebuilt binaries, however it is still prone to mistakes or they could make changes to suit there needs in there distro that might be not so good.

The prebuilt binaries as paul says should run on any distro, and if it doesnt you get support, theres no support for distro provided packages or self bult versions which is understandable.

the permissions issue while annoying is a good thing, it shows that security is working as it should. unfortunatly for the non long time linus user and even for some long time users like me, permission cause issues until you fully inderstand them.

i will pay… once i’ve proven to myself that i can get it to run as smoothly, and grief-free as say, propellerheads Reason. Back when i tried the demo of Reason 1.0, it became immediately apparent to me that it did what i needed, and was the most stable piece of software i have ever used – and i use a LOT of software, from simple, to very very complex. Reason proved to be worth something. And because of that, i bough it. I will donate to/buy Ardour, once i’m convinced i’ve started using a fully functional, reliable, extremely-low-frustration tool that suits my needs, and doesn’t just turn out to be just several weekends of lost creative time due to techno-crisis-nightmare circus wrestling. =)

I made the mistake a LONG time ago of paying way too much for Cubase – and that was one of the most worthless purchases ever. Each time i sat down to use it i could produce repeatable crashes – and when i’d go to their forums and explain these things, and ask for the functionality they’d advertised, which i had paid for in good faith, they kept trying to blame it on EVERYTHING else but their software, like the OS, the machine, the weather. I wound up getting better support from the pirate community. Imagine THAT! The company which accepted my funds, wouldn’t help me, but the hacks WOULD. And i though one of the selling points of legitimately licensed/paid software was the support – boy was i wrong. By the way, i thought this was more of a technical forum, than a marketing forum.

btw, i solved part of the problem by just deleting ~/.config/ardour3

i had use my admin account to set a couple things up, and wound up in a catch22, because Ardour in my daughter’s account was for some reason pointing to one of MY folders which she didn’t have WRITE permissions for, and maybe her Ardour config was directing Ardour to my config folder… and i couldn’t get into the settings of Ardour to change where it was defaulting it’s session storage to because IRONICALLY, you can’t get at Ardour’s settings unless you can either a.) successfully open an existing session, or b.) successfully open a new one.

Once i deleted the configs, i got out of the loop.

Now, on to solving my jack techmare

i do appreciate the help here. Has helped me solve some problems, and for others, at least given me an idea of the right direction to look in

“can jack seriously NOT use the laptop’s speakers (built in audio) for monitoring/playback, while at the same time take it’s audio INPUT from the presonus audiobox usb??),”

The latest jack1 should be able to, jack2 will need an additional client loaded, either alsa_in and alsa_out, or the zita equivalents zita_a2j and zita_j2a. This web page has more info on the zita variants:

My understanding is that enhanced variant has recently been incorporated directly into the jack1 code, but I do not know if any distributions are shipping that variant yet or if you would currently have to build from source to get that. You can use the stand alone versions of zita_a2j and zita_j2a with any version of the jack server.

Any routing system which lets you use an external interface and the on-board sound hardware is either doing the same thing behind the scenes without telling you, or you will get occasional dropped buffers because of running two sound interfaced with asynchronous clocks. There is just no other way around that problem.

The easiest setup would be to either use headphones with the Presonus interface, or some small powered speakers connected to the Presonus interface. Either (headphones or external speakers) would avoid the hassle of bridging clock domains. If you really don’t want to do that for some reason, the newest jack1 or the stand alone zita programs would provide better sound quality than alsa_in and alsa_out, but alsa_in and alsa_out have the advantage of shipping with all the older versions of jack server, so you likely already have those installed on your system.

why would you want to use laptop speakers? using poor speakers can make for frustrating mixes that sound ok until you try the song on other systems and find theres too much sub or the lows are muddy.

Theres no point having a nice interface if your using poor speakers to mix

its not so much of a question that it can’t it can be done with some hacks but its not recomended.

Buy a set of sienhiezer hd 202 headphones (£30) and monitor from the interfaces headphone out.

“anahata is right, its not so simple to use one interface for input and the other for output, while there is hacks to that could make 2 seperate interfaces work together, getting them to synchronise would be a problem.”

i’m thankful the authors of Ardour didn’t shy away from the task of creating it, because “its not so simple”.

p.s. i got it to work. EASILY. using an alsa_in, and alsa_out command. sometimes you have to naysay the naysayers.

etyrnal: nobody said it would not “work”. The observation is that you shouldn’t be working in this way. Yes, we all know the people they have no choice in their particular circumstances. But it is the wrong way to do digital audio. We made it possible, but that doesn’t make it right.

Have a look at

this may get what you want working with jack

as for the permissions issues, you may need to ask in your distro forum on a solution as its not caused by ardour.

Ardour is open source software so anyone is free to download the source code and built it themselfs. Paul only provides support binaries that are provided from ardours site which is undertsandable. As who knows what has been done to the distro provided binaries.

What distro are you using?
im not sure that having a user with administrative privliages is recomended. I dont think its very secure to have a user logged in as admin.

if anything needs to be done that requires root privilages it usually asks for the root password. that way administrative rights are only accesssed when needed and a password is required everytime you need to do something which could potentially harm the system.

I dont know what ubuntu is like these days but i didnt like how the system security had been relaxex the last time i used ubuntu studio. Things that used to ask for root password dont anymore.