Adding a plugin makes audio suddenly go to the left channel only

I haven’t changed my workflow, but for some reason ardour is behaving differently.

I’m a beginner with ardour despite using it for a long time; I only understand it a little, but at the same time, I have a basic workflow that has been getting the job done for me for quite some time. I record a single track through a single mic. As far as I understand, it’s a mono track, but I don’t understand if ardour supports stereo tracks. All I know is I’m recording a single source to a single track. I can pan left or right. I can add plugins.

All of a sudden this evening, when I added a plugin (calf compressor [not calf mono compressor], which I’ve used in this workflow exactly like this probably 100 times or more), the audio suddenly started coming out of only the left earpiece. I thought it must be a hardware issue even though it happened exactly when I added the plugin (from my favorites; the exact same plugin I’ve used tons of times), so I started spinning my headset plug and twisting dials on my audio interface, but nothing helped. Finally I removed the plugin and suddenly the audio was in both ears again!

I closed and reopened ardour thinking it was a glitch, but the same thing is still happening. I haven’t changed anything, but now I can’t use plugins. Add a plugin, and the audio disappears from the right earpiece. This has never happened before, and I haven’t changed anything, and I can’t figure out how to fix it. This is weird and stressful. Anyone have any idea what the heck is happening? Thanks!

Yes, it does. But, typically, microphones and instruments like guitars are mono instruments.

There are cases where you can have stereo mic setups, or guitars (for example) going through processing units which give stereo output. In these cases you can create a stereo track.

But for mono sources, like your mic, you would normally have a mono track as you are only capturing a single channel.

However, the normal master bus output is configured for stereo and you have pan control to select how much of each of your mono tracks you want to go to the master bus left/right.

Effectively, your mono track is actually mono-in, stereo out. And you can see this if you look at the audio connections, as your mono track will have L and R connections to the master bus input:


I’m not sure why that’s happening. It might be worth checking your pin connections. It should look a bit like this:



It shouldn’t matter whether you put the plugin pre or post fader.

Have you tried using the mono compressor?



Adding a link to the Ardour manual for signal flow reference:

Note that the plugins come before the panner so, up until they hit the panner, everything on a mono track is still mono, so a plugin can’t change the balance.

It may be worth checking you definitely have a mono track, and not a stereo one by mistake. Can you post a screen shot of the track strip with the plugin inserted?

Also, are you adding the plugin to the track, or to the master bus?



Hi, Keith, thank you so much for your help!

I did try the Calf mono compressor as part of troubleshooting and it didn’t cause the issue, so if all I wanted was a Calf compressor on a mono track, I’d be able to work around it with that, but I also want to use other plugins that also triggered the issue (like the Calf reverb, which doesn’t seem to have a mono version and also triggered it – seems like stereo plugins triggered it and mono ones didn’t).

So after reading your helpful replies, I went and looked at it again, and in particular I looked at my outputs and clicked more boxes in the matrix to put the green circles in there, and now I have stereo sound again!

I definitely don’t understand why adding a stereo plugin triggered this and removing it resolved it, especially when it’s never worked that way until tonight, but I’ll try to read that section of the manual, and in any case I’m back up and running for now, and I really appreciate you taking the time to walk me through it. Very kind of you, and much appreciated!

1 Like

I think I know the issue.

When you create a track, make sure it’s set to “Strict-I/O”.

If it’s set to “Flexible-I/O”, when you insert a plugin with a stereo output it (sort of) changes it to a stereo track and, in that case, you’ll get only one side of the plugin connected even though you have a stereo output.

By the way, this can be set to default tracks to Strict-I/O within the preferences, and the default setting is for Strict-I/O, so you may have changed this.



By the way, you may want to look at other plugins. Apparently the Calf Plugins, although they have a great GUI and are easy to use, have some issues.

I’m not the expert on this, but one of our resident gurus, @x42 may be able to give better advice.



This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.