add the missing master track

I’m working on a session where at the beginning I decided to handle everything myself, disabling all the options in the session control window.
Then my session is without a master bus track.
Actually I would like to have a proper Master track back but I don’t find the option to do it.
I’m managing to route everything to a new Bus Track, that is not exactly the same.
Is there the option “add a master bus” somewhere?

Thanks in advance

There is no such option.

However, please note that a master bus is special in only 1 way: if you set up the session to auto-connect track outputs to the master, then that will happen.

This means that you can simply add a bus, connect the tracks to it, and you have exactly the same setup. You can even call it “Master” :slight_smile:

3.0 will have a feature similar to the one you are asking for.

Thanks Paul,
adding a new bus and call it MasterBus is exactly what I did.
But then I have to fiddle a bit more to route the signal to it, in fact it doesn’t appear in the track Output list (like the proper master does) and I have to edit the routing.
It doesn’t appear in the Export Window as well (like the porper master bus does) and I have to fiddle with the “selected track” option.
Nothing impossible, of course, but you know…

if you really want to hack it, you can always edit the session file. Find the <Route> called “master”. change or add the property “flags” to be “MasterOut”, so that the Route definition starts like this:

<Route flags="MasterOut" ......

then save, load it into ardour, and it will be a “real” master bus :slight_smile: