About latency and multitracking in Windows

Hello,

I use Ardour with Linux mainly, but lately I have a need to use Ardour in Windows 10 and without a specialised audio interface. When I use Ardour in Linux without an interface there is no problem recording with the metronome running and keeping any subsequent recorded tracks in sync. On Windows however with the MME driver, if I record the metronome itself, played through the laptop’s speaker, onto a track, there is a delay once the recording is replayed from disk. My first question is, am I doing something wrong for this to be occurring?

My solution has been to measure the delay in samples of a recorded metronome click from the preceding bar line and use this number in the hardware input delay field in the audio settings. Is there a better way? For example with a 44.1kHz sampling rate and the buffer set at 4096 samples there was a delay of approx 4866 samples.

Thanks a lot and sorry for any silly misconfigurations that I may have done.

Iain

There is always a latency involved in computer based audio of some sort, but it might be small enough not to worry and Ardour tries to adjust as best it can.

That being said, on Windows I would suggest using ASIO instead of MME, the latter of which has a significant latency compared to ASIO.

  Seablade

Setting the systemic Hardware I/O latency is the correct approach.

You can try the “Calibrate Audio” tool, which is available from the Audio/MIDI Setup Dialog.

This plays a chirp to measures the round-trip latency (and automatically sets the systemic-latency). However this method usually only works when using a cable: output -> input.
Speaker + Mic is often not reliable enough.

If the goal it to minimize the latency: you could try http://www.asio4all.org/ in case your soundcard does not have an ASIO driver. In many cases that allows to run reliably with smaller buffersizes compared to MME.

We’ve added Windows/MME mainly with the intention to allow listening or mixing on-the-road, playback only.

1 Like