A little problem trying to use my MIDI expander with Ardour 3

I’ve juste bought (yesterday) a Roland Integra 7 MIDI expander in order to use it with Ardour 3.
But there’s something strange happening : Ardour seems to reset the expander’s settings (instruments choices) when it starts playing the song from the begining !

Here is what I do, and what happens :

  1. I have written a tab in Guitar Pro 6 (of a song from my own band). My purpose is to transfer it to Ardour to re-record some of the tracks with better sounds from the Integra (especially drums), and re-record some other tracks with real instrument/vocal takes, then mix it in Ardour.
  2. From GuitarPro, I export the tab to a single MIDI file, containing all the instruments parts in dinstinct channels
  3. I created an Ardour 3 project in which I imported that MIDI file (each channel to a separate track)
  4. Still in Ardour, I assigned each MIDI track to a different MIDI channel, and linked their respective MIDI outputs it to the expander in QJackCTL (the expander is USB plugged). At this points it works just fine ! :)
  5. Then, on the expander I choose the sounds I like for each channel (a nice drumkit on ch. 10, a clean guitar on ch. 3 ...) and then I save these settings in the expander's memory

Everything seems perfect, except when I rewind to the very begining of the song : then, when I hit the “play” button it resets all the expander instruments choices back to default !!! :frowning:

That doesn’t happen if I start playing from anywhere else than the begining.

My guess (can you tell me if you think I’m right or wrong ?) is that there must be a “program change” MIDI message sent to the expander at the very begining of the song, or something like that … but WHY ?

  • Do you think it might be Ardour who sends it for some reason ? In that case, could someone please tell me where I can find some documentation about it ?
  • Or does it HAS to be some unwanted data imported form the GuitarPro's MIDI file ? And in that case, how can I see and edit MIDI data other than notes in Ardour 3 ?
  • Or if you think it's neither Ardour nor GuitarPro, how can I investigate on this ?

I’m a beginner with MIDI and I could really use some help, please … thanks :wink:

Have you tried playing back your MIDI-file with another application, for example Rosegarden? Does the effect occur there too?

You could try the following workaround: Leave in GuitarPro four measures rest at the beginning of the piece. After importing the midi file into Ardour you can trim those away in the imported region. By that you might trim away the annoying midi sequence.

I will try this tonight when I’m coming home then I’ll let you know about the result.
Thank you for your help, johmue :wink:

So :
it is indeed some MIDI data at the begining of my Drum track :
muting the drum track or trimming it’s begining does prevent the problem to occur.
But it is still not satisfying, because trimming the drum track also cuts some notes that are part of the song (and the song starts with a drum solo intro !).
How do I see and edit MIDI data other than notes in Ardour 3 ? I think when I’ll be able to do that, it will really solve my problem :slight_smile:
Again, thanks for your help.

Problem solved !
It was a “Patch change” (I didn’t noticed the little rectangle at region’s top left corner).
I removed it and now it works perfectly :slight_smile:
I found it in the “Reference Manual” : http://manual.ardour.org/editing-and-arranging/editing-midi/using-patch-changes/
Thank you for your help, johmue :wink: