a-Fluidsynth Reverb ON by default on restart

Hi folks,

I’m currently using Ardour 5.12 on Linux Fedora 32. I have a couple of heavy-unfinished projects under 5.12 so I’m a bit reluctant to upgrade to v6 until these are done …

So under 5.12, I’m using many instances of a-Fluidsynth and I’ve noticed something which is very annoying.
My soundfonts are set, Patch selected, the Reverb switch is OFF, all good and happy with the sound.

If I close Ardour, re-open and load my session, everything seems good BUT the sound produced by the FluidSynth plugins do have Reverb even though the switch is OFF in the GUI. If I turn the switch ON then OFF again, then the reverb is gone and I’m good to go.
So it looks like it’s initialized in a default “Reverb-ON” state which is not reflected by the GUI switch …

I found myself adding these Reverb setting as controlers in the channels so that I can at least reset all these reverbs manually more efficiently (without having to open the full a-FluidSynth GUI)

Have you experienced this behavior of FluidSynth ? For me it’s not the first time, I had the same issue on my last projects too.

Vincent.