32bit floating recovery question

I am recording with a Zoom F6 in 32bit floating. Some tracks are sometimes saturated. What is the right way to retrieve the track information in Ardour, just Alt+7? If I do that I can see in the waveform that the saturated areas are marked in red in the waveform.

Without having the files at hand it is hard to judge what really happened. But if the recordings really are recorded too hot and therefore distorted, there is not a lot you can do to “remove the clipping” afterwards.

I would strongly recommend to turn down amplification already at recording stage. Don’t hesitate to keep a couple more dB extra headroom in the future…

But my question is: Do you hear the distortion? Does it cause real problems for you? Or is it more of an theoretical “optical problem”? I got visibly clipping files a lot of times to work on and very often it didn’t really matter all that much…

If you really do hear the distortion, maybe try Noise Repellent, which has served me well on a couple of occasions in the past (although it is usually used to remove other kinds of “noise” on a recording, maybe it can help you too…)…

Is the sound really distorted or is it just the waveform that exceeds the track’s bounds ?

It doesn’t sound distorted, I imagine it’s only 2 to 5 dBs more at most.

Anyway, my understanding was that by recording at 32 bits you could recover the information later:

Just normalize it to sane levels, maybe ? Or use the range select tool and pull the gain down where it’s needed.

It’s classical music, it should bring the whole track down to the same level.

Here is a screenshot of what the waveform looks like after lowering the gain with Alt+7

it looks totally fine to me.
Alt-7 applies a -1dB gain to the selected region, so you could go on and do the shortcut again until its not showing red anymore.
The red just shows that the signal exceeds [-1:1], which is what you can expect with 32b-float recordings. So either normalize the whole track to -3dBfs, or lower the volume at the track fader, or apply a few dBs of negative trim, or lower the master volume…

Id go with normalizing the offending track to -3dBfs, so it wouldn’t show red anytime at playback.

That waveform is after having applied a reduction of 11 dBs with Alt+7.
It will always appear in red even if you reduce 25 dBs and the waveform is minimal.

Maybe it still shows red because the gain is not applied to the source material. Bounce it.

Sorry, but I don’t quite understand what “Bounce it” means, perhaps because of my English… What should I do concretely?

(My earlier answer showed that I don’t have much experience with this new kind of 32bit-recorders… So although it is still possible to overload microphones and preamps in 32bit in theory, it won’t happen all that often anymore probably…)

If you don’t need the indication of clipping in the waveform display, why not just turn it off? Ardour global settings/display/editor → uncheck “show clipping in waveforms” (or something along those lines - I had to translate…)…

Right-click on the region. Select the menu item that has the name of the region. Just below “export”, there are 2 “bounce” option, one with effects and one without effects.

@laex 's idea sounds good too.

My suggestion would be to try importing the source file into Audacity, see if you can recover the clips. Audacity definitely can do what you want. Maybe then compare the waveforms of Audacity’s and Ardour’s rendering. At my previous job we used a F6 to record, then imported into Audacity to recover clipped sections.

If you’re still not sure, maybe do a test recording on your F6 with a simple sine or triangle wave, something with a shape where you easily see if it is recovered correctly. Set the input gain too hot. Ardour should display the red marks. Then see if you get the correct Waveform when lowering the region gain.

I would suggest doing this in Ardour first, as I suspect the region may not actually be clipped.

Leaving aside what 32 bit float recording actually does, Ardour shows the red areas based off a math formula that assumes traditional 24 bit recording or similar. As a result any value above a set amount will show red IIRC. If the value is recorded above that amount, but the waveform is not actually clipped, it will still show red.

So this also comes back to the rule, ‘Does it sound bad?’ essentially you have to use your ears and not just depend on visual tools with sound. Listen first and foremost. I can’t count the number of times I have used tools and visual information, then listened and determined I needed to throw all that away and go back to square one with my ears instead.

If your ears are not hearing distortion (And assuming you are trained enough to hear distortion) then don’t worry about it so much and depend on what you hear, not what you see.

1 Like

“Recover” is really misleading here, as 32 bit float audio dynamic range is 1528dB (yes).
770 of these are above 0dBFS.
There are few chances that the audio is really clipped : the data is there, you just have to normalize to 0dBFS, or -2 if you really want to avoid inter sample peaking.

In general you are correct, but the 32 bit format itself doesn’t guarantee no clipping, that really depends on the AD/DA process, what a lot of those recorders are doing though is having multiple different AD/DA processes with different gains and merging those back together into a single file so that you have a much larger dynamic range than would be possible off a single AD/DA process (Similar to HDR shooting on digital stills cameras, it is still possible to clip, but it gives you more flexibility and less concern about it). Even with three different 24 bit gain stages (typical) and converters, you are still nowhere close to 1528dB dynamic range in recorders, closer to about 150dB in ideal circumstances though which is typically more than enough.

1 Like

Metallica, Rick Rubin and the engineers did that with “Death Magnetic”.
Didn’t turn out so well… :brick: :brick: :brick:
Guess they weren’t trained enough to hear distortion :rofl:

Slight difference when you do it intentionally:)


The 32bit FP files produced by the F6 never really clips: the level may exceed 0dB (thus apparently clip), but the signal integrity is preserved (unless of course the input signal is already clipped by the mic or some external device, or if you send an input signal exceeding the F6 max allowed input level, e.g. if you send a line level signal to an input configured for mic mode).

If Ardour is importing the files in 32bit FP and uses that format internally, just lower the gain (e.g., using “trim”) or normalize the track, and you’re done.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.