2.8.4 Unsuccessful Download

Hey, great program. Love it!
I’ve been trying to install 2.8.4 today. I’ve tried about 10 times, and each time the download stops and says “The operation cannot be completed.”
Not sure why… any ideas? I’ve tried it in both Safari and Opera.

The issue is with the host providing the files sadly. At this point just go ahead and redownload till it works. The issue is being worked on though.


I don’t want to be a pest, but I’ve tried over 40 times now. I don’t think it will ever go through if it hasn’t so far.
Is there any alternative download? I’ve searched for a 2.8.3 download from other sites, but they all lead to ardour’s download page with 2.8.4.
Thank you

Did you already try clearing all your browser’s cache, history, etc, and tried again?

Yeah, It’s ok. I’ll wait for the fix.

@gileadid: i believe that i have fixed the most likely source of the download problems. let me know if it helps you out.

It’s definitely downloading faster, but it still won’t finish (about 5 tries). I’ll keep doing it, though. It might go through.


are you on a very slow line, say would it take more than 30s to finish the download?

Oh yes It takes about 25 mins. That’s part of the problem I’m sure.

Oh yes It takes about 25 mins. That’s part of the problem I’m sure.

IP over pigeons? :slight_smile:

No, but seriously: The cause is now evident.

I’ve been having problems too (on a slow slow net connection), but just tried again and the download completed fully this time :slight_smile:

It worked!
Thank you!