16 seconds playhead delay

Hi! I’m sure this is just some setting but I can’t find it.
When I click play, the playhead waits around 16 seconds until it moves. It also records where the playhead is (16 seconds too late).
It only happens in one project and only since recently so it probably has nothing to do with jack or anything.
It’s probably a very useful function when you want to do recordings and microphone and speakers are several kilometers away from you but it just drives me crazy right now.
Any help appreciated!

Do you have a latent plugin in that session? ssj71’s tape-start has a very long latency for example

About 5.5Km for 16 seconds…

Useless info aside, check your record buffer settings in the settings as well and make sure that isn’t turned way up. This can help with stability when tracking many tracks at once and I do this when tracking 64+ tracks for instance.


Good point! In between I had a plugin to shift the vocals down and selected maximum buffering but I removed it and the effect is still there…

I have around 5.3ms delay from that (according to the green numbers in the top right)
Also, I used qjackctl to set jack up and it works in another project with the same settings.

When I do
cat project.ardour | grep user-latency
it lists all the plugins I use and they all have user-latency of 0
Also, if I hit play, the sound starts playing right away, just the playhead doesn’t move.

I noodled around a bit with git and everything, in the end I didn’t change anything but now it works again :confused:

user-latency="0" means, use the latency as reported by the plugin.

Are you using ardour-6.0-pre.XXX ? and not 5.12? If so that can well explain things. Transport control is undergoing complete overhaul and isn’t ready to be used.

Ah good to know.

I am using 5.12. I just have my project.ardour file under version control, that’s what I meant. I tested a previous version and it worked fine, then I compared the previous (working) version and the recent version in a diff tool, then it became too annoying, then I tested the new version again and it suddenly didn’t have the problem anymore. I don’t know what was going on…

Maybe a plugin that caused the delay and then it wasn’t removed right away when the plugin was removed?