1 xrun every 5 min, UR22

Steinberg UR22 MK1, doing fine, but there is exactly one xrun after more or less every 5 min all day long. Any ideas? UbuntuStudio, 5.10. Two or three periods doesn’t make any difference. Not class compliant but works so far.

Doesn’t bother me much, I’m just curios.

Check for jobs running in the background on a schedule, such as a chron job.


Hi seablade,
it’s a fresh UbuntuStudio with KX overlay, is it possible there is something running by default? Still new to Linux, still learning, found nothing along var, spool, anacron etc.
It’s interesting that only UR22 is affected, while Scarlett 2i2 is not.

Check your JACK buffer settings, USB interfaces used to require something odd like 3 buffers or 3 periods or whatever the weird JACK terminology is, in order to work reliably.

Well, I have some other interfaces running smooth and reliable with Jack, so I don’t think it’s a general problem with Jack. I also tried 2 and 3 periods with no avail. Buffer at 1024 also doesn’t solve it. But as I said it’s no big problem, I’m just curios to find out what causes it. Thanks for your help.


Do you use laptop?
If you do, try to disable wifi card (not just disconnect, but shut it down completely so that it doesn’t scan for available networks).
In my limited experience that is the main culprit for periodic xruns.

I think other members of this forum can give you more technical details of why this is happening, but as I recall it has something to do with wifi card and USB bus sharing the same “interrupt” (what ever that may be) and when wifi card is scanning for available networks (in exact intervals) it jams the whole “traffic” for the specific “interrupt” so audio data can’t pass through and xrun happens. You can check interrupts list in the file /cat/proc/interrupts and see if the usb bus and wifi card share the same number ( let’s say 16 or 17). Sometimes it helps to plug the USB cable in different port, but the safe solution is to switch off wifi card.

I may be entirely wrong, but I hope it helps.

Thanks for all the good advices, will check them. Still strange that it’s only the UR22 with the problem, Focusrite and also my 15 years old Terratec Phase 26 USB is working nicely.

I guess I narrowed it down. I have two Macbooks running Ubuntu Studio, one of which is fitted with additional (proprietary) drivers for WIFI. Ubuntu doesn’t install them, you have to download them via Ethernet first, only after that are you able to use WIFI. The laptop without WIFI driver is doing fine. The other one gives me the xrun every 5 mins, even with WIFI disconnected.
Shall we say solved, or shall we ask what is touching WIFI every 5 minutes?
Thanks for your help, everybody.

It is not enough to disconnect wifi, you need to switch it of. You can do that in network manager (click on wifi icon or put it in “flight mode”), and there should be no available networks. You can do it in terminal with command: sudo rfkill block wifi . (and for switching it on again sudo rfkill unblock wifi ).

Thanks, will try. Although I have to stress that it’s only the UR22 with the reoccuring xrun, my other AIs are fine. Could it be possible that this one is trying to call home regularly? How can I find out?

Maybe your UR22 is just about to break down and these are the first symptoms. If the computer and the USB cables work with other audio devices, then the culprit can not be anything else than the UR22 itself,