[SOLVED!] Stereo Effect Plugin Not In Stereo? HELP!

I’m new to Ardour, so probably dumb question. I can’t get my Stereo Effects (delay, chorus, etc.) to output stereo. I’m using 5.12, just added a mono track for my strat, but want the stereo effects to help widen the sound, but they aren’t in stereo. I looked through the input/outputs on ALL tabs and can’t find any solution. I’m using the latest version of AV Linux. What am I doing wrong?

By default adding/removing plugins won’t change channel-count. mono-track will stay mono. In Ardour this is called “strict-i/o”.

If you want a mono-track to become stereo when adding a stereo-plugin, use “flexible-i/o”. This an option when creating a track, and you can later toggle it: In the mixer-window, right-click on the color-bar at the top of a channel-strip and disable “strict-i/o”

See also http://manual.ardour.org/signal-routing/signal-flow/

1 Like

Thank you, Robin!!! That was it!! Sounds sooo beautiful now with the GVST Trichorus and some Dragonfly verb!! Look out Michael Landau! :wink:

Most of the times I keep “strict I/O” but go to the “Pin Connections” dialog, where I select “Manual configuration” and add an output. That avoids adding another channel by mistake, or ending up with 4 channels if I add a Xfade or splitter later on.
I also hate that without strict I/O, the number of outs don’t decrease automatically, so if removing a plugin creating more outs, you also have to go to the routing grid to remove the extra channels.
Note that I know that’s intentional and I am not arguing that “flexible I/O” should change. I am telling that I prefer strict I/O, with manual overrides when warranted, and maybe that’s what you want too if all other sides of strict I/O suit you.