Noise Removal and Optimize Audio for Video

And rx6 has a full working 10 day trial as well. We await your report :wink:

Maybe somebody who has worked on both SoundSoap and iZotope RX can give us a comparison. I used to work as a sound engineer for 16 years, but early this year I changed careers and I’m an IT person now. In my old life I would have tested SoundSoap right away, but now the only audio stuff I do is writing music with Ardour, recording only “clean” sources. I no longer have a personal need for noise reduction.


See above:)

As I mentioned, SoundSoap was an ‘easier’ to use solution, Izotope was capable of much better reduction. I used to own Soundsoap, switched to Izotope, haven’t looked back really.

As I said Soundsoap may have improved, but it would have had to have been significant to match what can be done with a bit of work in Izotope’s destructive editor for instance. Pretty sure the realtime processing was even better in Izotope, but honestly the destructive editor/editing is what allows you to get some pretty good results.


Just an update on noise removal/filtering. I transferred some interview cassettes to digital and that had a lot of unwanted noise. One audio engineer commented that the recordings were beyond hope. But then, another audio engineer not only filtered out the noise and restored the audio, he used Reaper ReaPlugs to do it! (Which are free.) He took snapshots of how he did it. Reaplugs works on Wine just fine. That said, I am still waiting for Noise Repellant to be in reposReaPlugs is a pretty durn good tool set to have.

@Fanthomstory what distro are you using? I can provide easy install instruction for you. Noise repellent is really easy to compile and install you shouldn’t wait for it to be packaged in any distro. This is a useful link for the previous discussion on sound soap vs izotope Believe me I’ve read all the papers and technically rx is a way ahead of every other tool. The link above is from the guy who created rx denoising algos. Noise repellent is inspired in his work.

@lucianodato Currently I am running Ubuntu Studio. that seems t be the only thing that works okay with my graphics card (which still has issues, but less than other distros). I have tried to install Noise Repellant last night, but had difficulties. If you can give me a step-by-step, that would be great.

As for RX et al, sure if you can fork-over buckets of cash, I am sure there are all kinds of great solutions. I get more impressed with people who do amazing things with more modest solutions. Mind you, this looks like exactly what I am looking for: But it seems I need buy their hardware to get it. Maybe later this year they will have something for ‘the rest of us’. I look forward to using Noise Repellant, though.

Detailed procedure for ubuntu and derivates:
1- Open a terminal
2- Write the following comand:
sudo apt update && sudo apt-get install lv2-dev libfftw3-dev python3-pip ninja-build git
3- Then write this one:
sudo -H pip3 install --upgrade pip
4- Then this other:
sudo pip3 install meson
If those command have run correctly you have what is needed for correct building of the plugin. So next up is getting the plugin.
5- Now clone the repo from git with the following command:
git clone && cd noise-repellent
6- Now we have to give permission to the installer script in order to run with the following command
chmod +x
7- Then you can run that install script using the following:
Note that in all those steps you may be asked to introduce your user password in order to proceed. With all that done the plugin should be recognized by your DAW next time you open it. Instruction to use it are in
Please if you have any trouble at all don’t hesitate to contact me here or in IRC (I’m “arguy” in #ardour channel)

it compiles well enough.
i do it sometime and had not get errors.
i use standart package system and try to not install things without packages.
below - today’s build of noise repellent for debian. hope, for ubuntu it will be usefull too.
for those pupil, who not need to waste much time for true packaging, “checkinstall” is as well as needed.

Thanks eugeen!

@lucianodato Thanks, I did get it installed. I have the plugin and am trying it out on some projects and will get back to you on it. Thanks for doing this as it is one of the missing pieces for DAW plugins in Linux!

On Arch - based distros you can compile the source package from Arch repo (tested on Manjaro):

git clone
cd noise-repellent
makepkg -sf
sudo pacman -U --noconfirm *.pkg.tar.xz

@fathomstory Great! I’m rewritting the plugin right now and hopefully migrate to DPF to make a gui for it. It’s a code mess right now but it works. Let me know what do you think of the results.

Yes I need waves type plugin for noise reduction. Professions have to work in less than ideal situations. Noise reduction is a must. Anyone one got one? I’ll pay

@MattDelRosso: if you actually read this thread, you will find that it is almost entirely about a zero-cost, open source plugin called Noise Repellent that gets close to “professional” results. Read backwards through the thread to find out more.

Hello, I’ve tried to use the plugin but it doesn’t show any interface in Ardour 5.12.0.

I’ve downloaded the 0.1.5 release version of the plugin from github and extract it to the /usr/lib64/lv2 folder. It appears in the plugin list in Ardour under plugins by creator but when I click on it nothing happens. I’m using ardour and lv2 in an opensuse leap 15.0. What should I do?

Probably compile it from source, or ask your distribution to do that.

A quick look indicates that the plugin binaries from (currently 0.1.5, Jan 2020) are dynamically linked, and rely on external resources (likely libraries from Ubuntu, not compatible with openSuSE).

Thank you Robin. I’ve compiled it following the instructions in the github page but have no success. It is still in the list of plugins but showing nothing when clicked on it.

Well, I’ve just recompiled the whole thing and found that there was an issue with [sord_validate found: NO] when running meson. After installing sord and sord-devel with Yast and recompiling again, the plugin is popping up an interface in Ardour. :slight_smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.