No sound

I am new to both linux and ardour but am excited to learn. What im not excited about is the sound decided to crap out for some reason… I had a project started, recorded a few things to test and I got audio playback just fine, in the headphones and through the laptop speaker. Saved project, came back later that day to test record some more. I noticed that the laptops built in mic was active, effecting the recordings, so I went to the volume control the mute the built in mic. Everything was grand, or so I thought, until I attempted to record again with no auido playback! I have done lots of research at this point to figure out, as I am not much of a forum person but I have tried everything that I have read.

I tried starting qjackctl and connecting the appropriate outs and ins. I have tried going to the mixer in ardour to connect the apropriate buses (or at least I think)
I have been constantly checking the volume of my speakers…just in case you know…

I noticed this problem, like I sated, after successfully attempting to mute the laptop mic. I even went back and un-muted the mic in hopes that it might bring me back to where I once was.

I am super excited to use ardour4, and Ubuntu to continue my music career, but I cant get past this issue… it has been 3 days now of spending most of my time trying to fix this… please help!


On a command line console, try
cat /proc/asound/cards

If you get a list of more than one sound interface, the first, numbered 0, is the one that will be used by default.
It’s quite common for the interfaces to be initialised in a random order at startup so your default sound card isn’t the same each time.
Advice such as given at may help, but there’s also a way of creating a file in /etc/modules which forces the priority or blacklists the modules (and hence sound interfaces) that you don’t need.

Start QJackCTL and click on setup.

Then locate the box named “Interface” and click the arrow on the right side of it pointing to the right (do not confuse this with the drop down menu arrow that points down). Here you can see the list of sound devices on your system, select the one you want to use and click “Ok”.

Click on “Start” on the QJackCTL interface to start Jack.

Now start Ardour and Select Jack as the audio Backend

In this picture I have selected Presonus Audiobox 1818VSL as the audio device.

on linux, ALWAYS prefer names like “hw:DAC” or “hw:HDSP” to “hw:0” or “hw:1”. The former will not change; the latter can change which hardware they refer to on every boot.

See also:

thanks anahata, I tried a few(it keeps doubling the first couple lines not sure why…) different things in that link you gave me, although it seems to be for older linux stuff. I even went to the page of configuring advanced controls in alsa and was able to manually turn up all the volumes of the different devices, but no luck yet. also the page seemed to be for issues with no sound at all, which is not the case for me.

Mharzel, thanks! this pretty much worked, except it makes me wonder how I was able to have the scarlet 2i4 hooked up at the same time. I think the problem was that I was selecting the scarlet 2i4 as the device… but now im not sure how make it all work again lol… with the scarlet hooked up and the audio going out to my sound card. but this brings me alot closer to where I need to be, thanks!

thanks everyone, this is all helpful.