Latency on Mic recording

Hello,
I’m on ubuntustudio 18.04 with ua-25 ex usb and Ardour 5.12 alsa based.

When I’m recording, I can hear my voice in my headphone, after quite half second.

What can I do to hear in realtime what I’m singing?

Thanks in advance!

Hello

You should either lower the latency settings if your hardware permits it or use a direct input monitor mixing if your hardware permits it too.

What are your audio settings at the moment?

By the way for having using both I find ubuntu studio 19.10 way better for setting up things as cpu governor, it performs better in my case.

You have to tweak it a litle to perform better

I don’t have that device but after checking the manual: https://static.roland.com/assets/media/pdf/UA-25EX_OM.pdf it seems you have zero latency monitoring on your device and you should use that.

You hear your mic delayed probably because the sound travels through Ardour to your headphones. This always takes some time and causes the delay. You seem to have “Direct Monitor” on your device and that lets you hear your mic immediately on your headphones without any delay.

Disable monitoring through Ardour and turn on “Direct monitor” on your device by pushing the switch “Mon SW”. Now set the physical “Direct Monitor” knob on the device in the middle position. Now you should hear your mic connected to the UA-25ex without delay and you should also hear tracks playing in Ardour.

1 Like

I had mon s/w turned on already on my soundcard, so I switched in preferences “record monitoring handled by” from ‘Ardour’ to ‘Hardware’.
Now I don’t hear any delay.

Thank you so much!

ref.
https://manual.ardour.org/recording/monitoring/monitor-setup-in-ardour/