I get no sound when I use Fluid Synth

I have Linux Mint 20.3 on a laptop HP EliteBook 840 G7.

I have installed Ardour 7.1.0 (rev 7.1) in Flatpak.

I am able to play midi tracks using the Reasonable Synth.

However, if I use the Fluid Synth I have no output sound…

I have tried several SoundFonts, with no result: if I hit the keyboard on the edge of the track editor (or when the head crosses notes in the editor chart) the yellow meter moves, but no stereo green meters.

I have the same routing grid than in the Reasonable case…

What could be wrong?
I would be happy to provide screenshots and any other info.

Thanks in advance!

Fabio

1 Like

I don’t know if it is related, but some plugins don’t work with Flatpak (because the program is isolated/sandboxed). I believe Reasonable synth comes embedded with Ardour, thus it works.

To be sure try the demo version that you can download from Ardour website, to see if the problem persist.

2 Likes

I have installed the demo version, but the problem persists.
I noticed that in the demo version, together with reasonable synth and fluid synth, I also got General midi synth… which is missing in the version I got via flatpak…
In the demo version both general and reasonable work, and fluid doesn’t.

I have solved it!
Actually, the suggestion from @Piergi, although didn’t work per se, has lead to the solution: I have launched the demo from the terminal, so I have been able to read the error messages. It turns out that I was using the wrong format of soundfonts, so that FluidSynth was not loading them. Reading the error message led me to understand the situation!
Thank you! :slight_smile:

1 Like

My tip: Use the official download version of Ardour. Other or Flatpacks make problems - i had that too.
Fluid Synth needs SF2 Soundfonts

For your installation, i can recommend my tutorial.

1 Like