Behringer UMC1820 And Ardour

This sounds like a problem I ran into with my UMC1820 and ADA8200. Yes like Paul said it has to do with syncing.

There is a switch on the back of the ADA8200 right beside the Sync - connector. If you use only one Adat cable running from ADA8200 to UMC1820, then you need to set this switch to: Master 44.1 kHz or Master 48 kHz. Then turn off your UMC1820 and set the push button: OPT I/O to ADAT. Turn UMC1820 on and start up alsamixer and change the UMC1820 to sync to: ADAT. Now it should work again :slight_smile:

Thanks for all your answers !

Even with two adat cables, no mode of synching is getting any signals on a >#10 tracks.
I can succesfully lock the preamp in slave with the two cables, so these aren’t in trouble.
My config is :
Ubuntu Studio 18.04
Advanced Linux Sound Architecture Driver Version k4.15.0-39-lowlatency
Alsa 1.1.3
Ardour 5.12
Jack 0.4.5

Do you know of any mean to “ask” the soundcard how many input it’s treating ? I have 20 tracks listed whether I have the cable plugged in the “ADAT IN” of the UMC1820 or not, so I’m suspecting a hardware failure of this port.

10 tracks? Maybe this is a silly question, but on the front of the unit, do you have the SPDIF/ADAT button selected correctly? I am not home at the moment, so I am not sure if ADAT requires the button be depressed or raised, but if you have it set to SPDIF, I think that would limit it to 10 tracks.

Well it’s just the UMC has 8 XLR ports +2 others. So the tracks from 11 to 18 are from the adat. And yes, I’ve tried everything. I even tested to use adat in spdif mode in case it was switched, out of despair…

Have you changed the UMC1820 sync source to be adat ? This can’t be done in hardware it must be done in software for example using alsamixer.

Yep, tried with the three of them. I’m kinda running out of idea here. Hence my suspicion for the hardware.

You need two working adat devices to rule out which device/port is faulty. You could try to connect UMC1820 adat out to ADA8200 adat in and see if there is sound at the ADA line outputs. You’d need to change sync settings around also.

I’m seeing a friend with a fully fonctionnal chain this sunday on another OS, so we’ll see the bottom of this ! :slightly_smiling_face:
Thanks for your concern anyway, I’ll keep you guys in touch, for reference.

Okay, so. I managed to have it working under windows (after installing the drivers) on tracks 7/8, so I assumed it was a driver-related issue. Now I see it working perfectly on these tracks, but 1-6 remain dead silent. I’m trying some voodoo with a windows driver and wine, but I honestly am not optimistic.
Does it ring a bell to you, an adat with only 2 out of 8 tracks working ?
Another thing I find deeply disturbing is that alsamixer does not list these two additionnal tracks.

Behringer’s site still states that UMC1820 is supported under MacOs and they have no driver download for MacOs. So the device must still be USB Class Compliant and installing any drivers probably won’t help with your problem.

UMC1820 Adat track numbers are 11 - 18, so I guess your are talking about ADA8200. But now I’m confused because there is no drivers for ADA8200 for any os.

So which one of your devices is not working as expected, is it the UMC1820 or ADA8200 ?

Anyway if either of these devices are not working as advertised, then just send it for repair. Behringer build quality is not good and you may need to swap your device for a new one to get a working one. My first UMC1820 was broken, but the second one works fine. If one adat channel works then all the other channels should work also, if not the device is broken.

Hi guys,
So I have this friend of mine who’s running on windows. On windows you do need a driver and a software to have the UMC working. In it you have access to every track and can set small parameters, such as gain, mute, etc…
Turned out, the tracks 1-6 of the ADA8200 were reset to mute every time I was connecting to Alsa from my linux.

So I finally gave up and cleared completely my OS before installing a fresh new ubuntuStudio (18.10), and there it was : magic, every thing working absolutely fine. So my guess is there was some old config files from alsa doing havock.

Thanks for your help !

1 Like

Hi,
I’m just getting the Behringer UMC 1820 to run in Ubuntu Studio 18.04 out of the box!

You can change WordClockSource and muting of ADAT-Channels in AlsaMixer.
You can watch this: https://www.youtube.com/edit?o=U&ar=2&video_id=5NiOb-LkHlU

I was able to have 0.7ms latency with 96kHz.
You can hear (or not) here: https://www.youtube.com/watch?v=_5aLlaC6RD4
I was also able to use the 8 optical ADAT I/O without any problems.

The only thing was to get rid of puleaudio:

I did some tests and recordings to show setup, two time monitor-mixing, ADAT and latency demo on youtube: /channel/UCINH_Fh0Ego_IWIVed3RUmA

It’s in German but you’ll get the point.

I like to use an RME 96/8 PAD on my old PC. That PCIe Card was an expensive on!
The UMC 1820 was about 180,- Euro, and now I’m able to use USB an a newer Laptop
for recording.

I’m locking forward to test the Mic-Preamps against the ones build in my old Yamaha O3D.
You will hear that on my YouTube-Channel, next weeks.

Enjoy,
Thilo

I started with UMC404 and upgraded to Umc1820. Worked out of the box

As a question :How can I use both units ? in other words 4 input channels of the umc404 and 8 input channels of the umc1820 ? Qjackctl does not allow for it.

thanks

You have a few options. I do not think these boxes allow external sync (word clock for example) but if both of them do, then it is possible to create an alsa_multi pseudo device that looks to jack like one device with all io from both boxes.
Option 2) even if the two boxes may be synced together, it may be easier to use zita-ajbridge with the synced option (-S).
Option 3) unsynced use of zita-ajbridge. This uses software syncing also known as SRC (Sample rate conversion).
Option 4) use alsa_in and alsa_out which come with jack, they are similar to zita-ajbridge but I am told, do not do the SRC as well as zita-ajbridge does. “Not as well” means doesn’t sound as good and uses more cpu. (I have not tested if this is true) So far as I know, alsa_in/out does not have a synced option, it is SRC only.

With all of these options you obviously want to use the unit with the greatest i/o as the jack master. You do not want to have an stereo pair cross both units (if left is on unit (a) the the right should also be on unit (a)). The master unit should be used for things that are loudest and most important in your mix (lead vocals and lead instruments).

@lenovens , thanks for the reply !!! I am currently busy in other areas but will come back to it and keep you posted.

thanks and best regards

Otto_oz

From Len’s comments I would suggest you try Zita first. I once did a few tests with a bass and a stereo pedal to split the signal and recorded both on Ardour as two different tracks using a Scarlet 2i2 and a Uphoria UMC with 2 inputs. For the test I did with alsa_in there was a small but noticeable delay from the second interface while using zita I could not notice it.

Hello, since some users of the umc1820 and ada8200 have the same problem (alsa is muting some channels)
i have found out a quick solution:

open a terminal window and type in the following:

alsamixer
press F6 to select sound card (in this case UMC1820)
The displayed sound-cards are starting with 0 (that means the first one has the value zero, the second one the value one and so on)
Find out the right value for your umc1820
Exit alsamixer by pressing ESC

type in the following lines: (the value after the “-c” parameter has to be changed to your sound-card number that you just discovered in alsamixer. In this case change the “2” to your own number)

amixer -c 2 cset numid=1 on,on,on,on,on,on,on,on,on,on,on,on,on,on,on,on
amixer -c 2 cset numid=3 127,127,127,127,127,127,127,127,127,127,127,127,127,127,127,127
amixer -c 2 cset numid=9 on,on,on,on,on,on,on,on,on,on,on,on,on,on,on,on
amixer -c 2 cset numid=11 127,127,127,127,127,127,127,127,127,127,127,127,127,127,127,127
amixer -c 2 cset numid=8 0
alsactl store

The lines will enable all outputs, enable all inputs, set all output volumes to max, set all input volumes to max and set the clock to internal .
that last command will store your configuration.

this did the job for me without reinstalling the whole os.

do it on your own risk!

3 Likes

Hello all,

Audio interface newbie here! I 'd like to ask the following questions regarding this Behringer unit:

  1. When used as a plain USB sound card (eg, YouTube, media player, etc) does the USB send audio to the main outputs as well as headphones? Follow up questions for this scenario:
    1a. WIll the audio coming from USB get mixed with the 1-4 inputs when the mix knob is set all the way to the left (IN position)?
    1b. Have you experienced any issues with the sound (when switching from the onboard sound card of your PC to the audio interface) getting either high or low pitched (as if you play vinyl records in higher or slower speeds)*
  2. When powered on does ALSA/alsamixer remember the volume levels for each input/output channel from the last time it was used? **
  3. Can it work on its own without turning on my PC (standalone mode, for example just hooking up the speaker cabinet simulation output that my guitar amp attenuator has for silent practising).

FYI, I 'm on KDE Neon (Ubuntu LTS based distribution) using Pulseaudio. Thanks for any response :slight_smile:

  • I get this behaviour sometimes with a Scarlett 18i8 1st Gen with or without JACK being involved
    ** With the Scarlett 18i8 1st Gen this is not the case, but I can workaround it with alsactl
  1. Yes.

1a. No, that is the point of setting it to the “IN” position, to only hear the inputs. Conversely, if you set it fully to the “PB” position you will only hear the USB playback. Setting the dial at twelve o’clock gives a 50/50 blend of the inputs and USB playback.

1b. No, but this likely due to a sampling rate setting difference between the two interfaces you are using. One probably defaults to 44.1k and the other 48k.

  1. Unlike the 18i8, the UMC interfaces have no internal routing software. Powering on the interface will have no effect on the ALSA settings you have stored.

  2. I am not entirely sure what you mean by standalone mode. It is a computer audio interface. What would you be accomplishing by using it without a computer? Are you wanting to use it as a headphone amp? I have not tried this.

Hi Gunther,

Thanks for your response:

  1. Can you set the Mix knob in between positions or is it only IN, 50/50, PB?
  2. With regards to sampling rates, doing some more reading my understanding is that Pulseaudio handles resampling. You can configure it so that the sound card follows the source’s sampling rate, but I haven’t tried that and it is suggested to better avoid it. I need to investigate this a bit more.
  3. You can save Scarlett 18i8’s routing/mixing in it’s internal memory using Focusrite’s software and use it as a mixer without connecting it to a PC. I appreciate that the UMC1820 has a default routing which you can’t change, but the question is can it be used without turning on my laptop, eg, just connect a source in one of its inputs (in this case speaker cabinet simulation) and hear the audio from its main outputs and/or through heaphones?