Barlow Arpeggiator goes into bypass mode?

you do :slight_smile:

The PBD::warning message ends up the Log window.
And when process returns a non-zero value (here -1), the plugin is disabled

@aggraef A massive improvement! So, on load-up of the project. It plays like it should! It works, until something happens and the same behavior starts again. Closing the project and reopening does not fix it. Closing Ardour, restarting it, and loading the project fixes it.

I was able to replicate this problem. I played the track several times. It was OK. I simply added another blank MIDI track, with only General MIDI Synth. I then played from the beginning, and the same bug (stop at measure six) returned on the first playback after adding the blank MIDI track.

I do have Ardour 8.1.50-Debug installed. Would running in debug mode be of help? I can also update my nightly, as I think that would be a good idea. I may wait until 8.1.113 is built. After using linux, I am annoyed by the Win10 installer :slight_smile:

Let me know if you need me to try something.


FYI, the audio interface Audio Kontrol 1 is NOT a USB-Compliant device, if that makes a difference.

And switching back to ASIO4ALL, it works!

It is a mystery how the Audio interface can have any effect on this at all!
The audio/midi backend is entirely decoupled.

Do you use the same buffersize with ASIO4ALL and the Kontrol 1?

Yes. 512 for both drivers. In the ASIO4ALL, I noticed that the Kernel Buffers was 2. In my Audio Kontrol, USB Buffer was 1ms.

For the sake of this post, I am going to assume that Kernel Buffers is similar to USB Buffer.

When I changed Audio Kontrol to a 2ms USB buffer, barlow worked again! I changed back to 1ms, broken. Back to 2ms, working!


Updated to 8.1.115. Problem persists. Uninstalling the Win10 (p)OS will resolve this issue. :slight_smile:

It is impossible to the audio driver settings to have any effect on Ardour Channel Processors.

I could imagine that perhaps dropouts (xruns) cause discontinuities.
Or perhaps more likely: msec sized buffers at 44.1k causing the plugin to run at odd step-sizes, which may cause issues with Tempo-map/positions calc.

The only way the plugin will bypass itself is if an exception is throw, and that should be logged in Window > Log.

Ok. That makes perfect sense.

There are no x-runs that show up in parenthesis in the upper right indicator. I cannot hear anything unusual either

It does bypass itself, but nothing is shown in Window > Log.

I was able to run Ardour Nightly 8.1.115 in debug mode. When the error happened it showed in GDB:

LuaException: [string “ardour {…”]:696: attempt to perform arithmetic on a nil value (local ‘w’)

@x42 This error did not show up in Windows > Log, but did show up in the Win10 GDB version debug log.

Should this LuaScript error be showing in the Ardour Window > Log ( or the red indicator in the upper right ) ?

Or is there a separate output log in Ardour for LuaScripts ?