Audio Interfaces Under Linux


(Mikael Hartzell) #81

Miditech Audiolink III

Works in Linux with both a USB 2 and a USB 3 port (tested with Kernel 4.9.68-1-rt60-MANJARO) and Jack 0.125.0-3 (Manjaro package) with Sample Rate: 48000, Frames / Period: 1024, Periods / Buffer: 3.

I don’t recommend this device for anybody because there is not enough of Mic and headphone amplifier gain for basic audio work. Also as soon as one starts Jack there is a silent but annoying 1 kHz tone on the headphones.

The Zero Latency Monitoring is not adjustable and can only be turned on or off. If you want to have less Mic in the headphones the only way to do this is to use the Mic knob which also affects the recorded volume.

This device is USB 1 Audio Class Compliant and does work in win10 without a proprietary driver (using microsofts usbaudio.sys).


The forum spamfilter didn’t let me post the full details of cat /proc/asound maybe because it printed a lot of text. So here is the short version:

The device supports playback sample rates 32 kHz, 44.1 kHz and 48 kHz and 8 and 16 bit sample sizes. Supported recording sample rates are: 8 kHz, 11.025 kHz, 16 kHz, 22.050 kHz, 32 kHz, 44.1 kHz and 48 kHz and 8 and 16 bit sample sizes.


cat /proc/asound/CODEC/usbmixer
USB Mixer: usb_id=0x08bb2900, ctrlif=0, ctlerr=0
Card: Burr-Brown from TI USB Audio CODEC at usb-0000:00:1d.0-1.3, full speed
Unit: 3
Control: name=“PCM Playback Volume”, index=0
Info: id=3, control=2, cmask=0x3, channels=2, type=“S16”
Volume: min=-32768, max=0, dBmin=-12800, dBmax=0
Unit: 3
Control: name=“PCM Playback Switch”, index=0
Info: id=3, control=1, cmask=0x0, channels=1, type=“INV_BOOLEAN”
Volume: min=0, max=1, dBmin=0, dBmax=0


(Seablade) #82

@mhartzel

Nice, thanks for all the work.

       Seablade

(Jtaffuri) #83

I recently purchased a Behringer UMC404HD it interfaced fine with my JACK, Ardour set up in Mint 18.3 Cinnamon. I am just another person having problems with click, crackling and pops. To me it seems it only happens when I use Ardour. I have my quad core i5 CPU in performance mode but have read some folks may have solved the problem by changing buffer size and sampling rates. If you have experience in resolving the problem please let me know. Thanks!


(Keith Milner) #84

I should add to this…

I while back I got hold of a Behringer XR18. This is an 18 channel mixer which also has 18 in and 18 out USB and it works beautifully in Linux. It even has a free downloadable Linux app to control the extremely capable, mixing and routing capabilities in the unit itself via the network.

It has 24-bit resolution at 44.1 or 48kHz.

As it’s, fundamentally, a standalone mixer, then this unit has some fantastic routing and mixing capabilities, and also some onboard FX. For each of the 18 inputs you can select whether it is an analogue input or a USB output from the computer. For analogue inputs, every channel has a gate (with sidechain), EQ, and compression, as well as an FX send to each of the 4 onboard FX slots (which can be loaded from a range of FX including guitar amps, vintage style compressors and reverbs, delays,chorus, etc.).

16 of the inputs are “combi” style connectors (Jack or XLR) and two are jack line level inputs. Combi inputs 1& 2 are Hi-Z so you can DI guitars and basses.

There’s 6 output busses in addition to the stereo master bus, and you can also route the output of any channel to the PC over USB. The mono busses and channels can be ganged together to form stereo pairs.

Controlling the unit is done using the free PC, Mac, or Linux (yes!!) app, and there’s also an iPad and Android app. Control is via the network, and the unit can either act as a station on an existing wireless or wired LAN, or can be switched to act as a standalone wifi network for stage use.

This gives a fantastic degree of flexibility. To give some examples of how I’ve used this.

I have this connected up with Jack, so I see an 18-input/output device (you can switch this to 2-channel mode if you want). I have a Mic on one channel (it has phantom power and phase options), and guitar and bass DI’d on channels 1 & 2. I also have a synth and a guitar FX processor plugged into other channels. I often do Google Hangouts, and sometimes I will mess around with my guitar during these. I have configured 2 stereo busses, one outputting to my desktop monitor speakers, and one acting as the mixing point for USB “send”. I have headphones plugged into the monitor jack on the unit which is on the master bus.

So this basically allows me to create separate mixes for:

  • Headphones
  • Monitor speakers
  • PC

So if I’m in the middle of a Hangout, I can listen to my noodling on the guitar/bass and the Hangout audio on my headphones, whilst the hangout hears my Mic audio, but not the guitar/bass. I could also choose to let the hangout hear the guitar/bass if it’s a social hangout.

I can also push Pulseaudio sound out of the PC on a channel, and mix it into any of the busses. Again this allows me to selectively and separately mix the audio from (for instance) Youtube to the speakers, headphones, or back to the PC (e.g. to a Hangout). I’ve used this, for instance, to play a backing track on the PC and play along on the guitar, performing into the Hangout.

Conversely, I can also set the gate on the microphone to duck the mic based on the guitar or bass input, so if I am in a conference call, I can mess around on the guitar and they won’t hear the strings through the mic. Another use for this is so that, when performing to a Hangout, the mic doesn’t pick up any acoustic string noise or fret buzz.

Cheers,

Keith

P.S. I removed the links to the appropriate parts of the Behringer wiki as these seemed to trigger the spam filters.


(Gennargiu) #85

hi i have a used lexicon alpha,berhinger uca 200,behringer uca 222. All soundcard work good in gnu linux debian stretch 9 with repository kxstudio. No problem with ardour 5.12,Mixbus 4,tracktion 6 and 7 Qtractor and various other programs dedicate audio production. I have a test maudio firewire solo with driver ffado. Are two days it’s work in debian stretch with repositories kx studio
gennaro


(Mikael Hartzell) #86

I just had a chance to briefly (for 1 hour) try out the Behringer UFX1204 mixer with Linux. The device is a USB Class Compliant device and works out of the box with Linux.

My Linux system:
Manjaro Linux with kernel 4.14.80
Jack 0.125.0
Alsa: Advanced Linux Sound Architecture Driver Version k4.14.80-1-MANJARO

The device lets you record 16 channels which are:

channels 1 - 12 are hardware inputs (Mic, Line, etc)
channel 13 is the Aux channel
channel 14 is the FX channel
channels 15 - 16 seems to carry a mixdown of channels 1 - 14.

I only had one mic (SM58) with me so I could only get signal to one input at a time, but I recorder all the 16 channels simultaneously with no problems while connecting the mic to the inputs 1 - 4.

The test was not very thorough but everything I tested worked fine. Here are some detailed info I grabbed from the device:

cat /proc/asound/UFX1204/stream0

BEHRINGER UFX1204 at usb-0000:00:14.0-1, high speed : USB Audio

Playback:
  Status: Stop
  Interface 2
    Altset 1
    Format: S32_LE
    Channels: 4
    Endpoint: 2 OUT (SYNC)
    Rates: 44100, 48000, 88200, 96000
    Data packet interval: 125 us

Capture:
  Status: Stop
  Interface 1
    Altset 1
    Format: S32_LE
    Channels: 16
    Endpoint: 1 IN (SYNC)
    Rates: 44100, 48000, 88200, 96000
    Data packet interval: 125 us

cat /proc/asound/UFX1204/usbmixer

USB Mixer: usb_id=0x13970002, ctrlif=0, ctlerr=0
Card: BEHRINGER UFX1204 at usb-0000:00:14.0-1, high speed
  Unit: 212
    Control: name="USB-Bus (SOF) Validity", index=0
    Info: id=212, control=2, cmask=0x0, channels=1, type="BOOLEAN"
    Volume: min=0, max=1, dBmin=0, dBmax=0

Latencies

Jack started with: Sample Rate 44.1 kHz, Frames / Period: 1024, Periods / Buffer: 3.

jack_iodelay

  3300.665 frames     74.845 ms total roundtrip latency
        extra loopback latency: 228 frames
        use 114 for the backend arguments -I and -O

Jack started with: Sample Rate 48 kHz, Frames / Period: 1024, Periods / Buffer: 3.

jack_iodelay

  3317.689 frames     69.119 ms total roundtrip latency
        extra loopback latency: 245 frames
        use 122 for the backend arguments -I and -O

Here are some screenshots of QJackCTR:

Alsamixer didn’t seem to have any controls for the device: