Ardour crashes when exporting

I have been working with Ardour 7.4 for a few days and have similar problems as described here:

Ardour crashes on export. It may be because I am using DSP-hungry VST plugins with WINE and Yabridge.

What can I do to finish my project after completion? Record the midi tracks to a new track as audio using the VST instrument plugins, that comes to mind. It’s certainly not the ideal solution though.

If I take the trouble, and with the manual

do I get feedback from a developer? Or do I make the effort for nothing? Experiences?

I think Ardour under Linux is really great, I was happy to pay for it and would like to continue using it, as the workflow is very reminiscent of ProTools, which I used to use when I was still working professionally in the audio industry.

But if this problem can’t be solved, then I’ll have to look for other DAWs in the medium term, because the export function is essential.

I use Jack.

My Audio Interface is an Onyx Producer 2-2. I connected the Midi keyboard directly to the laptop via USB.

Now I found the following post: Jack audio custom buffer setting to maximize cpu

My questions:

  • How high can I go in jack with frames/period and buffer size without getting problems with latencies? Because maybe with higher values I can get the system stable and export?

  • Does it make sense if I try to run Ardour without Jack or is that even possible in my case:

If you’re recording and are using software synths or software guitar amplifiers/effects or similar you usually need to have jack set to low latency, to minimize the time from when you hit the key or pluck the string to when you get to hear the result.

When you’re mixing or exporting you can set it as high as you want with no drawbacks, to my knowledge, and benefits in lower DSP load.

So start by setting the buffer size to something like 2048 and see if that fixes the problem.

Using Windows plugins in Linux usually works fairly OK but I don’t think you can necessarily blame Ardour if it doesn’t.
It could very well be a bug in WINE or Yabridge that’s causing it and another DAW may exhibit similar problems.

I have set the buffer size high, incrementally to 4096 and periods/buffer to 4, but Ardour still crashes on export.

I am getting desperate as I am working on a project right now.

I had no problems with Ardour 7.2 until last time, now I’ll check if it’s because of the drum plugin (XLN Audio Addictive Drums 2) I inserted last time.

Any other ideas?

Okay, an dem Plugin liegt es nicht, es stürzt auch ab, wenn ich ein anderes Plugin verwende.

Jetzt schau ich mal, dass ich Ardour 7.4 wieder runter schmeiße und gegen die alte 7.2 ersetze, mit der ich keine Probleme hatte.

Do you use jackd or pipewire as JACK?

Can you try in Window > Audio/MIDI Setup to change the backend to “ALSA” (or Pulseaudio) and see if export works then

1 Like

Okay, I now have 7.2 on it again. Unfortunately with the same problem.

But @Robin: I took your advice and switched to “ALSA”. And lo and behold, it works with the export. You are great!

Unfortunately, I then don’t hear anything through the connected audio interface. So I have to switch back to JACK to work.

Or can I really somehow run Ardour without JACK WITH my onxy interface?

Now I install me so again the 7.4, because it should then also work.

Great :frowning: Now Ardour crashes when I try to connect to JACK again.

One problem was solved, but now I have another … What can I do? HELP!!!

Start by rebooting your computer; it probably won’t help but you never know.

Then start a Terminal and run mv ~/.config/ardour7 ~/.config/_ardour7 to make sure you haven’t got any weird settings in your config.

Then start Ardour from the terminal and post any error messages here if it crashes.

I rebooted the computer and started Jack. Then connected Ardour. And lo and behold, it worked again.

Problem solved - until further notice.

You should be able to.
If your interface is USB interfaced it should work without problem if the interface is USB class compliant (I think most of the Mackie interfaces are, it means they can be used with MacOS without needing a custom driver).

Are you sure you selected the correct interface? Post a screenshot of the Audio/MIDI setup window, perhaps someone will notice something you missed.
It is also possible that the ALSA mixer runs for your interface and reset the output levels. Not the most likely scenario, but worth checking if nothing else seems to explain why you get no output.

Are you using jackd or pipewire? If using jackd, how do you start the jackd server, from command line, from a QjackControl configuration, or some other method?

I do not work with MacOS, but with Linux.

Understood, the only reason I mentioned MacOS is that most interface manufacturers do not mention Linux support explicitly, but Linux ALSA USB driver should work with any USB class compliant interface, and MacOS and iOS also work with USB class compliant interfaces. The easiest way to tell if an interface should work well with Linux is to see if MacOS and iOS are supported.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.