Ardour 6.9 released

Ardour 6.9 is now available. Despite previous announcements that there would be no further releases for older platforms, it once again seemed right to do a release before we take some big steps into the future. This version features some substantial changes to both plugin and playlist (“take”) management, along with numerous bug fixes and improvements.

For more details, please read the whole release announcement .

Download as usual from


Excellent !!! Thank you !

… downloaded … will see how it runs

Best regards from Australia

Thank you Paul & team!

Funny sidenote: got it on Arch yesterday while it wasn’t yet even mentioned here, from their normal repositories. Runs nicely with Pipewire (my reason to install Arch beside Debian).

Oh, and 9to5linux has a screenshot from you (Paul?) with some commercial plugins like those from Waves? Is that a screenshot from Windows, or how did you get them running on Linux?

Thanks again, and cheers,

If it’s waves, it must be a screenshot from Ardour running on Windows or macOS.

Is it the screenshot from ? That’s Ardour running Window7 here.

1 Like

Yes, very obviously so :slight_smile:

1 Like

I just watched the mixbus video on the new playlist feature for managing takes and comping, and it looks amazing! Well done and thank you!

More regards from Australia :slight_smile:

Thanks for the release.

I think I found a bug. I’m using Ardour version 6.9 on Windows 10, and the routing grid won’t display i/o items properly, except for busses

Sorry about this, but I tried to create an account at mantis, but it wouldn’t let me set a password, reclick the confirmation URL, or let me get a new one.

Thank you.

I got an email from mantis notifying me of your account. What happens when you click the confirmation URL?

Thank you so much.

I’ll copy and paste what it said:


The confirmation URL is invalid or has already been used. Please signup again.

Please use the “Back” button in your web browser to return to the previous page. There you can
correct whatever problems were identified in this error or select another action. You can also click an
option from the menu bar to go directly to a new section.

This wasn’t this first time I clicked the confirmation link. The first time I did, I made it to the page where you set your password. I tried to set my password using that page, but when I tried to go to the next step after entering it, it gave me an error message that, if I recall correctly, had something to do with an invalid security token. Sorry about all of this.

I figured out what was happening with my routing grid. Apparently my track names were too long. I shortened them and now to grid displays better. Thank you.

I started trying Ardour 6.9 on a Mac Mini M1 (ARM64 build), I noticed the “MMC In” and/or the “MIDI Control Input” don’t get any Data; therefore I cannot control the transport from a Midi Controller (AKAI MPK249).

If I connect the same Midi Port to a regular Midi Track Input I can see the MMC or MIDI CC commands along with regular notes from the controller. The Midi Tracer on Ardour shows Midi Data (Control and Notes) only when capturing from the regular midi track input and shows nothing on “MMC In” or “Control Ports” (Misc/Sync Ports) (even when they show as connected from the Midi Ports Matrix).

I know at this point builds and/or code for MAC M1s might be considered “experimental” but I would appreciate any pointers to try get it working. I’ve been using the same Midi Controller with Ardour on Linux for quite some time with no major issues.


Does it work when you use the Intel version on the M1?

Does MIDI work in general when you use the ARM64 build? Can you play instruments on MIDI tracks, and it’s only MMC and control surfaces that do not work?

I just tried Ardour-6.9.0-dbg-x86_64.dmg on the same Mac Mini M1 and the transport works (plays and stops following MMC commands) with the same Midi controller (same settings, etc).

When I run Ardour-6.9.0-arm64.dmg on the same thing the transport does not respond to MMC. Playing Notes works fine (it seems it’s just an issue with the sync ports).
I even tried on a local build (ARM64) tracing the SysEx MMC messages in some parts of the code and they are there … just not in the “MMC in” or “Midi Control In” ports … But I guess this is not the forum to go more in details … Should I continue in the mailing list or IRC?

Thanks again!