Ardour 6.0 is released

Sorry about that. Another packaging mistake during the release process. This has been fixed now, so if you download again, it should be OK. It’s been too long since we did a release :slight_smile:

4 Likes

V5.12 was like a good old friend during these >2 years …
Farewell v5.12, welcome V6.0!!! :boom:

3 Likes

I just checked on two MacBookPro Laptops, One running 10.10.5 and the other 10.15.2 and in both cases Ardour starts (using onboard souncard).

1 Like

It was my fault. I had installed an old nightly that left some outdated files in the ardour preferences directory.
Deleting the Configuration Directory (you can find it in Files and directories Ardour knows about) fixed it.
Now it works like a charm :tada: :tada: :tada:

1 Like

Nice find! I should have thought of that.

1 Like

Actually it was @paul that gave me the hint in the bug tracker :grin:

Getting an error with Eq10q plugins: “failed to instantiate LV2 GUI”

I still have 5.12 installed, maybe it has something to do with it? other plugins seem to work fine.

It’s nothing to do with having 5.12 installed. What platform are you using (OS? if Linux, what distro and version?)

first impression: Does work extremely well here!! Congratulations for this outstanding work!

1 Like

I’ve been trying the new version and is really great!!! Also I feel like the user interface looks nicer than before! Thank you very much, as a music school teacher i really appreciate the improvements made to this tool, since it is open source and it allows me to do a lot of stuff with my students, even more now with the lockdown that I need digital tools to teach from the distance. The MIDI improvements make this easily usable for the kids to create their own music even if they don’t own a real instrument :smiling_face_with_three_hearts: Amazing work! Will become a subscriber as soon as my financial situation allows me to.

2 Likes

I just downloaded the TAR file for LINUX about 5 minutes ago, got the same missing revision.cc error. Thoughts please?

1 Like

Perhaps your download folder still has the old one, and the newly download one is Ardour-6.0.0.tar.bz2.1?

Debian 10. I’ve had some minor plugin problems before, like not showing up in categories list, but can’t recall a no gui error.

Edit: Gonna try the install from site solution given on the other post and report back.

here too KDE Neon
This tarball was not created correctly - it is missing libs/ardour/revision.cc

curl -s https://community.ardour.org/src/Ardour-6.0.0.tar.bz2 | tar tj | grep revision.cc

lists Ardour-6.0.0/libs/ardour/revision.cc QED

cristian@cristian:~/Ardour-6.0.0$ curl -s https://community.ardour.org/src/Ardour-6.0.0.tar.bz2 | tar tj | grep revision.cc

Ardour-6.0.0/libs/ardour/revision.cc
cristian@cristian:~/Ardour-6.0.0$ ./waf configure
This tarball was not created correctly - it is missing libs/ardour/revision.cc

Try this:

cd /tmp
rm -rf Ardour-6.0.0
curl -s https://community.ardour.org/src/Ardour-6.0.0.tar.bz2 | tar xj
cd Ardour-6.0.0
./waf configure
1 Like

In the indicated way, the process begins,
I find it strange behavior,
I’ve never had that problem