Ardour 5.5.0 metronome does not sound

Hi all. I am using the raspberry pi 3 B+ on raspbian with ardour 5.5.0.
Never had a previous version on it. I can’t hear the metronome playing back when it is activated. Audio through the tracks and master is good.
Everything else works, including automated faders.

Check if the metronome output ports are connected.
Menu > Window > Audio Connection Manager – Ardour/Misc Perhaps “Click” is not connected the soundcard’s outputs?

Another possibility is that the volume is too low, see Preferences > Metronome (or mouse-wheel on the metronome button). I don’t remember if that applies to Ardour 5.5.0 though. Preferably use 5.12.0


I’m still rocking Ardour 4 on my main recording computer and mouse-clicking the metronome button does in fact bring up the metronome section of the preferences menu, so I’m sure it is the case through subsequent versions.

All hardware and software connections are there for routing the metronome to the outputs. Still no metronome audio.
Please help!

Can you post a screenshots of your timeline and the audio connections window?

@drsaamah does mouse-wheel on the button to change the volume also work in 4.x?

PS. 4.x to 5.12 upgrade should be a no-brainer. 5.x is a lot more efficient, needs fewer resources and has all the optimizations that 4.x should have had. Session format is 100% compatible. Is there a specific reason why you stay with 4.x?

I am using Ardour 5.5.0 in /raspbian. No metronome output. I have a windows 10 version of Ardour, too. I will try the metronome there, too.
With having two raspberry pi’s, one a 3B and the other a 3B+, I found that both units would not play back the metronome.

Please post some screen-shots as @drsaamah suggested. That may shed some light.

PS, In the audio-connection manager it should look like

@x42, the mouse-wheel on the metronome button does not work in 4.
I haven’t switched yet simply because I am in the middle of a collection of songs and didn’t want to deal with learning the new layout. I actually just realized/remembered that I have 5.12 installed on that computer. If you promise session format is 100% compatible then I’ll make the change this week :slight_smile:

Yes, my audio connections are correct. By the way, in the Windows 10 version of Ardour, the metronome works perfectly and Hydrogen will play. In Raspbian, both the metronome won’t play in Ardour, and Hydrogen does not play, although audio from Ardour is fine, and audio will play back in Audacity, too.

I should note that I am using ALSA, not Jack for my Edirol UA-4Fx usb audio interface.

I also found that putting a custom click sound wave into the metronome function of Ardour also did not sound, instead of using the default metronome sound.
I got Hydrogen to play drum sounds back after I downloaded some alsa utils like alsamixer and alsaconnect and also found out that if Ardour is up and running, Hydrogen will not play back anything. Once I close Ardour, I can then have Hydrogen play sounds. Any way I can use them both at the same time?

Is there simple alsa patchbay/mixer that will allow you to play back sounds from different applications at the same time?

You want JACK, for routing audio between applications or share the soundcard for pro-audio applications.

When Ardour uses ALSA directly, it requires exclusive access to the device so that not other application can change settings (samplerate, buffersize/latency) and to prevent any desktop-sounds making it to studio-monitor speakers.

If those alsa packages were missing I wonder if you have a problem with dependencies. I have zero experience with raspberry pi’s, but I do believe they are a debian based distribution. Have you tried “sudo apt get update && apt-get upgrade” to make sure no other packages are missing? Then again, as Robin already pointed out, if you want to use Ardour and Hydrogen simultaneously this point is moot as you are going to need to use Jack. Try selecting Jack at the Audio/MIDI Connections dialog and seeing if that fixes your metronome issue as well.

You could also try Ardour 5.12 (arm binary from