Anyone know of a plugin to remove noise?


(Blackendwhite) #21

@ lucianodato seems the link is not working…


(Craigpidruchny) #22

Sometimes it’s not reasonable to expect to eliminate the noise at it’s source. Specially, some guitars are inherently noisy. If you put a noise gate on a guitar, as soon as you start playing, the noise will get through along with what you’re playing.
@ lucianodato Thanks for the plugin. It’s much more convenient than exporting to Audicity, editing the file and then importing it.


(Philippe) #23

@ lucianodato I’ve downloaded and installed the noise-repellent plug-in but would greatly appreciate an how-to or a video tutorial to use it efficiently.


(Blackendwhite) #24

@ lucianodato i m trying to compile it on manjaro / arch linux, can you tell me which sdk s i d need for that?


(Craigpidruchny) #25

I compiled it in Arch and I messed with the makefile. In the part about Library Detection I took out “lv2-plugin”. It built, but with errors. Then I copied the nrepel.lv2 folder to my lv2 directory. Not exactly an elegant solution but the plugin works, although there is only a generic gui. I’m not sure if it’s supposed to have a better gui. I would be interested in learning the proper way to build it in Arch is. I’m pretty sure that the there are no special packages with developer headers in Arch so the normal lv2 and libfftw3 packages should be good. I tried compiling lv2-c+±tools and was getting an error “undefined reference to `boost::system”. The only advice I could find about that was from unclear because it assumed a certain level of knowledge about gcc.


(Craigpidruchny) #26

There’s a package in AUR called lvtk-git which seems to be a fork of lv2-c+±tools. I see in the makepkg that, before configure, he did export LDFLAGS="-lboost_system".
I assume that would be the way to get around the boost error when compiling lv2-c+±tools.
As for the other dependencies of lv2 and fftw3, you probably already have them if you’re doing audio work. If not, they can be installed with pacman. Then you should be able to compile Noise Repellent without a problem.


(Lucianodato) #27

Hey Guys! This plug is a work in progress. Use it just for fiddling, it’s not anything serious right now. But I’m working on it. I don’t plan to make a GUI for it just yet. I must implement lots of lv2 features previously to making a GUI. And more important yet I have to refine the dsp. Denoising proves to be a tedious job and not easy at all, lots and lots of tradeoffs to work on.


(Craigpidruchny) #28

Still… it seems to work just as well as the noise removal in Audacity.


(Blackendwhite) #29

thank you guys for the insights, when i try to install the fork via yaourt lvtk-git i get: error: target not found: ttl2c

and yes if it “only” works as well as audacity this would already be fantastic as a lv2 plugin. i often have multitrack sound recordings i need to remove noise (dialog in cars etc…) so audacity is not really a choice in my workflow… for me a noise removal plugin is the only thing that really misses out till now in the linux audio world…


(Blackendwhite) #30

edit: now it worked! I needed to install ttl2c manually first…


(Blackendwhite) #31

@ CraigPid thanks for the install hints for manjaro/arch . I followed your example and get this error message: "install -d /usr/lib/lv2/nrepel.lv2
install: cannot change permissions of ‘/usr/lib/lv2/nrepel.lv2’: No such file or directory
"

the lv2 is build with errors and then it is visible as a plugin in ardour but wouldnt start in ardour or mixbus …


(Craigpidruchny) #32

Did you sudo when you installed.
Anyway… sorry, I didn’t mean to say that you could use lvtk in place of lv2-c+±tools as a dependency for noise repel. The files they install have different names. What you need to do is download the source for lv2-c+±tools. Extract the archive and open a terminal in the folder you extacted. In the terminal enter export LDFLAGS="-lboost_system". Then do ./configure, then make and then sudo make install. After that compiling noise repellent should go off without a hitch.
If you’re still getting errors maybe you need special dev packages for the other deps. I thought that Manjaro used the same repos as Arch but I could be wrong.


(Blackendwhite) #33

aah ok sorry i got it wrong… i m bad with that compiling stuff but maybe i ll learn by now :wink: yes Manjaro is based on Arch and uses the same repos!


(Lucianodato) #34

Hey guys! I fixed a bunch of thing and added some features in the dev branch (No more crackling distortion when reducing too much noise). I will clean up the code and make better documentation this weekend.


(Lucianodato) #35

There are lots of lv2 features I must implement yet, like atoms and states. The dsp part of it’s ok, maybe better than audacity in some cases. It sounds less echoie than audacity and CMSR is much better with musical noise (birdies chirpies). I will explain later in the readme file.


(Lucianodato) #36

Hey! It’s me again. I removed the lv2-c+±tools dependency so it should be easier to build in arch or manjaro. It would be interesting to see an aur package. Maybe I could do the script this weekend.


(Blackendwhite) #37

@ lucianodato great updates, your work is so much appreciated. I ll try again compiling on manjaro. Having an aur would be fantastic, although i have no idea how to do that ;(


(Blackendwhite) #38

ok, a little feedback from here. now it compiles smooth on manjaro / arch. unfortunately, when i try to find the plugin in ardour i cant find it, although it is copied into lib/lv2 … not sure what i m doing wrong, …


(Paul Davis) #39

use lv2ls to check your LV2 configuration.


(Blackendwhite) #40

it s showing up there:

http://zynaddsubfx.sourceforge.net/fx#DynamicFilter
http://zynaddsubfx.sourceforge.net/fx#Echo
http://zynaddsubfx.sourceforge.net/fx#Phaser
http://zynaddsubfx.sourceforge.net/fx#Reverb


[kalimerox@kalimerox]$

but here i get an error: when starting Ardour5, the commandline shows:

Scanning folders for bundled LV2s: /opt/Ardour-5.0.5/lib/LV2
error: failed to expand CURIE pprops:supportsStrictBounds' lilv_world_load_file(): error: Error loading filefile:///usr/lib/lv2/nrepel.lv2/nrepel.ttl’
KP is ardour.keys