About default skin

hi egag,
i just installed clearlooks following your link, but how i do “select that theme for the user”?

i am on debian + fluxbox here.


As I wrote, I’m now using the clearlooks theme, but Ardour2 doesn’t display correctly with it either.

strange enough, my last post went into the wrong thread?
can someone repare?

i use a little app called “gtk2_prefs” to set
a theme for me. You can get it here :

There are more apps to configure gtk themes; i only tried
this one and it worked ok for me.

I believe that, after selecting the theme, you have to log out
and in again for it to take effect. Not sure but it’s free… :slight_smile:

thanks egag, i did not knowed this theme-thing, everything looks better now!


For anyone still having display problems with Ardour2, I just corrected mine!!!

My screen looked much like the screenshots above in this thread, and it was driving me nuts…

The solution in my case was in the KDE Control Center, under Appearance and Themes/Colors. I unchecked the box at the bottom for “Apply colors to non-KDE applications” and Voila! Ardour2 now looks as it should.

I’m a pretty happy camper.

@ funkmuffin:

That is the EXACT solution on KDE!! Thanks. Gnome used to crash on me and now it runs finde in KDE…

Unfortunately the addition of the clearlooks engine to ardour2 still wont fix the problem that is resolved by doing the disabling of ‘Apply colors to non-KDE applications’ for KDE and whatever method there is to disable a given WM from altering GTK app themes. Being even more widget specific (as opposed to just doing magor damage with a few class definitions) in the rc file will fix the WM taking over ardour2 problem.

For me, it was as simple as changing the “GTK Styles” option at the top of the module in the KDE control centre under “Appearance/GTK Styles and Fonts”. I found that having it set to “Use another style” overrides parts of ardour’s theme so I changed it to the option that says “Use my KDE style in GTK applications”. Bear in mind that the fix is only useful if you use KDE and have the GTK-QT engine installed since the module won’t show up otherwise. You may have to be using a new-ish version of KDE too as I don’t think the option has been around for long. Anyway - the simple truth is that ardour should probably have more strict controls on it’s user interface that prevent any other program from changing the look - maybe an option to fix/set the UI to the default clearlooks setting on program load. I’m sure it could be done!
-zoops. :slight_smile:

Sorry to double post - but actually I found that keeping it set to “Use another style” but changing the dropdown to ‘clearlooks’ also works (since that’s what ardour uses! - but perhaps other styles work as well?) and looks a whole lot better when applied to other GTK applications than “Use my KDE style in GTK applications”. So this fix is preferable to the one above - if it works for you!
-zoops. :slight_smile: