A bit off topic: Confirmed Scarlett 18i6 works on Linux with Alsa 1.0.25

for now my DreamStudio 12.04 is only letting me install kernel i hope some fix is implemented soon, i just tried again the mixer x42’s writes about but get the same error still…

The Scarlett 6i6, kernel 3.11.2, alsa lib version 1.0.25 on Kubuntu 12.04 / KX Studio – the 6i6 still doesn’t work! It is not seen in lsusb or ‘cat /proc/asound/cards’. (The script alsa_utils_alsa-info.sh also doesn’t turn up a hint of the 6i6.) I thought for sure it would work based on gosvald’s report with his 18i20 and kernel 3.9…

Anyone have any suggestions?

BTW, gosvald, which distro are you running?


I have Scarlett 18i8 and i figured it can’t be much different than 18i6. I downloaded scarlettmixer driver for 18i6 and changed usb-quirk so it matches 18i8. Card gets recognized.
However i am getting “ALSA clock.c:265 >3:1:1: clock source 43 is not valid, cannot use” errors. And now i don’t know how to continue. When i try to aplay or arecord i am getting aplay: “set_params:1145: Unable to install hw params:” error

What would be alsarecord command if i wanted to capture 4 channel input and save it to file.

Late to the party… so just a quick heads up:

Complete support for Focusrite Scarlett 6i6, 18i6, 18i8 and 18i20 devices has landed in vanilla linux on 2014-11-13 (Linux 3.18) thanks to the effort of Tobias Hoffmann, Chris Arges and yours truly.

Heh thanks much, one more possibility to add to the list!


I think it’s in Linux 3.19. This is a great improvement for Scarlett devices, thanks to all the devs.

Very awesome x42. I just added spidf in to my 18i20, and can’t wait to try this out!

Hey x42, Does “Complete support” include being able to switch between line & instrument inputs from Linux?

@timfulton: Yes, this is supported. Note that I am using a recent 4.1 kernel, but I guess it has been possible since the 3.18 release that x42 advertised.

Aloha trying to get my Focusrite Scarlett 18i20 to work with Ubuntu 14.04 LTS. Vanilla Linux? Where is that? I’m looking for the most up to date solution. Thanks to all,
Melekalikimaka (Merry Christmas)

Aloha trying to get my Focusrite Scarlett 18i20 to work with Ubuntu 14.04 LTS. Vanilla Linux? Where is that? I’m looking for the most up to date solution. Thanks to all,
Melekalikimaka (Merry Christmas)

@Franklin Russell: With the 14.04.4 release of Ubuntu with the 4.2 kernel, I believe it should work now out of the box. I have had good luck with the same kernel in the non-LTS UbuntuStudio 15.10.

All - Is there any way to manage the hardware mixer from Linux in such a way that you can save your setup in between power on/off? The interaction between alsamixer and my Scarlett 18i8 seems a little flaky in that alsamixer does not always seem to recognize the current state of the hardware mixer when you open it up. Sometimes it does, and sometimes it does not. I have had a little luck using a Win10 Virtualbox guest to configure the mixer (not for firmware updates) but I have to close Ardour and stop jack before passing the USB port over to the VM.


Just wanted to everyone know that my Scarlett 18i20 is now working great with KX Studio made it work put up another badly done video showing it working. It seems work best when I start Jack at boot up. 128 2.7 latency is working. I changed it to 256 , but no need. I was getting out of memory xruns program freezes. I shut off MMC what is that anyway? I really want to learn more About Ardour.

It appears I can use all 18 ins and 20 outs. They appear in the Ladish tree as well as all 16 midi channels. Ill try that next with MTC starting up my Motif sequence.

Hi everyone,

Reviving this old thread because it was my primary reassurance that this interface would work with linux before I maxed out my credit card. My 18i20 seems unable to playback sounds. If I try to create an Ardour session with the Scarlett selected as both Input and Output device, ardour will not create the project. I realized after two days that if I only select the Scarlett as a recording device and select “none” for playback, I can create a session and in fact record those sounds (although without hearing them). I am on the 4.2 kernel, and all the I/O channels are showing in alsa mixer. I finally connected the Scarlett to my family’s windows box (a traumatizing experience) and updated the firmware, but I get the same results. Any suggestions? I am all out of ideas and very disappointed I spent so much on this interface.

@jessiejessup, did you ever get the Scarlett to work on your USB 3.0 ports? Im wondering if that’s my problem, bc I can’t figure anything else.

@drsaamah: not sure if you’re the same person as the user on IRC who has the same issue that you describe. This appears to be a problem with the kernel used by whatever Linux distribution you’re using. There are definitely users of the 18i20 on Linux who are using it with no issues.

Hi paul, yes i am the same person. The thing is since I disappeared from the IRC, I installed AVLinux (bc the most recent distro only comes with kernel 3.8 which didn’t recognize the scarlett at all so the live disc did me no good), updated the kernel to 3.19 and still had the same problem. Last night I went back to ubuntu studio, bc I don’t think that’s the problem (plus AVLinux has a weird wifi issue and is pretty ugly looking). Ive made a tiny bit of progress in diagnosis… as I mentioned above, the Scarlett is fine for capturing audio, its playback that’s causing the problem. As you mentioned, there are definitely people using the 18i20 without problems, that’s why I am trying to pick everyone’s brain to see what in God’s name is wrong with my setup :slight_smile:

I had the same problem as drsaamah was having and solved it by running alsamixer, selecting the 18i20 sound card (), then making sure that the Master Lines that I was interested in were NOT muted. In my case I had no headphone output and unmuted Master 4 (Line 7/8) which someone else said is the headphone out. Then in Ardour I assigned the Master Bus to Hardware/L-playback_1 and Hardware/R-playback_2. This gave me output to the headphones for all the tracks as their output was routed to the Master Bus. I realize you may have a different configuration, but this works for me. I have not tried powering everything off, rebooting the system to see if it stays. My system config is:
Fedora 22/KDE/kernel 4.4.6-201/Ardour 4.7 (64 bit)

Hi All
So is the consensus that the 18i20 will now work on one of the studio disto’s, out of the box , with Ardour?